Problems getting QtWebKit to Ubuntu



  • Hi,

    I have a project that I make on both Windows and Ubuntu.
    On the Windows machine it works flawless, but on ubuntu I keep getting "Unknown module(s) in QT: webkitwidgets".

    I've tried installing libqt5webkit5-dev. I've installed Qt 5.6 using the online installer.
    If I try to install Qt 5.5 I get an error saying "Error during installation (qt.55.qwebengine.gcc_64), Could not find the needed QmakeOutputInstallerKey."

    I know that QtWebKit has been deprecated for QtWebEngine, but I'm using MingW on Windows ( do not have visual studio), so trying to rewrite the program to use QtWebEngine will not happen in the near future.

    Any ideas on how I can get Ubuntu to detect webkitwidgets?

    Best regards,
    Anton



  • I installed 5.4 instead of 5.5, and now it appears to be working :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.