Qt Tutorial: "findLibraryInternal" runtime error / warning message



  • I realize this is an issue with something other than Qt, like KDE, but I can't find an answer in Google so I thought I'd ask here in case any of you have run into it and have a fix.

    I ran through the Qt tutorial at http://doc.qt.io/qt-5/tutorials-addressbook.html through Part 6 ("Loading and Saving"). It all seems to work as advertised but when looking at the "Application Output" in Qt Creator and hitting the "Load" button I get these messages:

    (9132) findLibraryInternal: plugins should not have a 'lib' prefix: "libkfilemodule.so"
    (9132) KPluginLoader::load: The plugin "libkfilemodule" doesn't contain a kde_plugin_verification_data structure

    One of my Google hits said to go to /usr/lib64/kde4 and say "ln -s libkfilemodule.so kfilemodule.so" to make a softlink to a library module without the "lib" prefix. I tried that and it had no effect.

    This doesn't appear at first glance to be hurting anything (but, of course, who knows what it's really doing in the background?) but I just wanted to see if any of you have seen that and have a solution.

    Thanks...

    Eric


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.