When will Qt support indicators?



  • I somewhere read that:

    Unity uses the new systray protocol called “indicators” or “notification item”, which Qt doesn’t support yet.
    Canonical developers have prepared a patch for Qt to add this support and to add support for the global menu, but this isn’t integrated into Qt yet.

    So when? I really need it.. I have send an email to Qt but no answer for about 3 days now :/



  • In reply to "some blog":http://comments.gmane.org/gmane.comp.lib.qt.general/41520 Thiago states that it may make 4.8 if the patches get accepted. If that isn't the case, 5.0 will be the earliest next candidate I guess.



  • If you need it that badly, you could also grab the Qt sources and compile your own version of Qt. OTOH, isn't the Qt version on Ubuntu patched already to support it?



  • No it doesn't support it.... Grab Qt sources and compile my own version of Qt? I don't think i am able to do it :P

    When will 4.8 or 5.0 be released? I just want it before Ubuntu 11.10 released.. So before 11 Octomber..



  • 5.0? Somewhere next year. 4.8? When it is done, but I think end of the summer somewhere.



  • So ubuntu users won't be able to make their apps stable for about a half year?
    My app uses system tray which is not supported by ubuntu anymore ( basically it is, but there are a lot of problems-bugs, plus not all users have accepted all apps to have system tray - there is a command that you should execute in order to see the systray to all apps )



  • Ubuntu decides to march off of their own, ignoring all standards and building a new desktop system from scratch, and you're blaming Qt that it takes a little while to catch up?



  • I don't really blame Qt but canonical has provided a patch the day 11.04 released ( not sure but around then ) .. Why not support it at 4.8?



  • I think it is because submitting patches is not as simple as "here code, integrate now".

    Patching the Qt sources and building is done in a few shell commands. If you are able to write Qt applications you are usually able to compile Qt from its sources :-)

    And - as Andre stated - i cannot imagine that there are no pre-patched binaries available for Ubuntu. They are probably just "hidden" in some unofficial repositories.


  • Moderators

    From what I understand the patch have some issues which need to be figured out before we can put it into Qt 4.8.

    This does not imply that the code is of minor quality or anything negative, just that some polish is required to make it work better on one platform or another, improve the APIs a bit, etc. A biggish contribution has to go through the legal department, too. All that takes a while. Having said all that: We have high hopes to improve the process of getting contributions into our code with the open governance process. Unfortunately I am not up to date with when that will finally become available, even though Qt Creator is doing a pilot of the process for a couple of weeks already. We can not wait to finally see the new process in the wild!

    Till the patch ends up in 4.8: Just use the Qt that your distributor has conveniently patched for you in your ubuntu version of choice. If you need a custom Qt, then just add the patch yourself and off you go:-) The sources are all there, you do not need to wait for us:-)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.