QWebsockets not working in winrt



  • Hi all.
    I can't get QWebsockets to work on the WinRT platforms.
    If I try to run the echoclient example it fails to connect to a server.
    Kits I've tried:
    QT 5.6.0 For Windows Runtime 64 bit
    QT 5.6.0 For Windows Runtime 32 bit
    QT 5.6.0 For Windows phone arm msvc2013 32 bit
    All with the same result.
    The code is working fine in windows classic / android / ios etc (server I'm trying to reach is accepting connections).
    What could be the problem here?
    Thanks in avance.



  • Is anybody able to verify that QWebsockets in fact is working in winrt 5.6.0? Otherwise perhaps I should file a bug?



  • I can confirm similar issues here. Code works on Linux, Desktop Windows, but not on any winrt platform. I've tried setting the various capabilities in the appxmanifest (I think you'll need internetClientServer and/or privateNetworkClientServer, I haven't tried any others), but the code still crasher inside some CAtlException :(.

    As far as I understand the release notes, QWebSockets should work in Qt 5.6. I also tried 5.7 beta 402 to no avail...

    I'll add my 2 cents to a bug report!



  • Does that error still exist for 5.6.1? I remember some fixes in that area, which were rather generic.

    If not, please to create an actual item on JIRA, as that is easier to keep track.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.