I can't link to a third party framework on OS X



  • Hello,
    I am trying to link to a third party framework on Mac OS X 10.11.3, Xcode 7.2.

    The framework is the SketchUpAPI framework. I use these lines in my pro file...

    QMAKE_LFLAGS += ../../SDK_Mac_16-0-19913
    LIBS += -framework SketchUpAPI

    I get this error...
    ld: framework not found SketchUpAPI

    I get the same error when I use a full path to the directory. An Xcode project has no problem finding and linking to the same framework.

    Why would qmake not be able to find the framework? Does it not understand the structure of the framework, or is it something more simple perhaps?

    Any advice will be gratefully received.
    Many thanks.



  • hi kenchan,
    in my case i got it in working in that way:
    QMAKE_LFLAGS += -F /pathtoproject/iOS/Antwerpes.framework
    LIBS += -F /pathtoproject/iOS/ -framework Antwerpes
    best,
    patrik



  • @patrikd
    Thank your suggestion worked fine for my framework too.
    Wish I could give you a cartload of reps for that :-).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.