QT Installation Issue on RHEL 5



  • Hi Team,
    I am installing QT on RHEL 5 and getting 'No such file or Directory' Error for libX11-xcb.so.1 library.
    My machine in not registered on RHN network, so i can't use 'yum' to installed it's dependent libraries.
    Please help me to get it's dependent libraries.

    Output:
    [root@localhost Desktop]# uname -a
    Linux localhost.localdomain 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
    [root@localhost Desktop]# ./qt-opensource-linux-x64-5.5.1.run
    ./qt-opensource-linux-x64-5.5.1.run: error while loading shared libraries: libX11-xcb.so.1: cannot open shared object file: No such file or directory
    [root@localhost Desktop]# rpm -i libX11-1.6.2-2.fc21.x86_64.rpm
    warning: libX11-1.6.2-2.fc21.x86_64.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 95a43f54
    error: Failed dependencies:
    libX11-common >= 1.6.2-2.fc21 is needed by libX11-1.6.2-2.fc21.x86_64
    libc.so.6(GLIBC_2.14)(64bit) is needed by libX11-1.6.2-2.fc21.x86_64
    libc.so.6(GLIBC_2.15)(64bit) is needed by libX11-1.6.2-2.fc21.x86_64
    libxcb.so.1()(64bit) is needed by libX11-1.6.2-2.fc21.x86_64
    rpmlib(FileDigests) <= 4.6.0-1 is needed by libX11-1.6.2-2.fc21.x86_64
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by libX11-1.6.2-2.fc21.x86_64

    Regards,
    Vikash Kumar.


  • Qt Champions 2016

    hi and welcome
    If its not possible to directly download it , cant use u a web page like
    https://rpmfind.net/linux/rpm2html/search.php?query=libX11-xcb.so.1&submit=Search+...&system=&arch=

    to get as RPM files and install those?



  • Many thanks for the reply.
    I tried the URL you have provide earlier but i didn't find any package for RHEL5. I tried downloaded the library provided for 'Fedora 21 for x86_64'. now, it is asking for others dependencies. i managed to download those except below Two libraries. i am not able to find it any where.
    Please help me out

    rpmlib(FileDigests) <= 4.6.0-1 is needed by libX11-1.6.2-2.fc21.x86_64
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by libX11-1.6.2-2.fc21.x86_64


  • Qt Champions 2016

    Sadly im on windows so have no way of copy those.

    Its not possible to get yum working ?



  • @Vikash-Kumar
    XCB libraries are not available for RHEL5. You'll have to try and build them yourself. See http://kate-editor.org/2014/12/22/qt-5-4-on-red-hat-enterprise-5/ for some help.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.