Cannot write curly braces



  • Unfortunately, I cannot write the opening curly brace { on a Hungarian keyboard layout. It works when I change to the English layout, but it is very inconvenient to swap between the layouts all the time. What can I do? Where can I set it to recognise the Hungarian keyboard?



  • There is a way to enter characters if you don't have the key on the keyboard. On Windows you would press 'Alt' then the numerical value of the letter. Pressing the keys 'ALT,6,5' would be the same as typing capital 'A'.

    It has been a while since I did this so my information might be a bit off (and I am not infront of a Windows computer) so you might want to google it. I knew someone who used to use this all the time with passwords (they always included a few characters that you couldn't directly type on a keyboard like 'Alt,2,5,5' or 'Alt,0').



  • Alt+123 as { works in a Notepad, but in Qt it opens the tabs at the bottom, i.e. "Issues", "Search Results", "Application Output".


  • Moderators

    If I got it correctly in Hungarian layout { is right alt + b and } is right alt + n. I switched keyboard layout to Hungarian and the latter seems to work ok. alt+b is by default a shortcut for build, so you migh want to change that in the keyboard settings (Tools - > Options -> Environment -> Keyboard).



  • Indeed, the right alt+B caused the conflict. Thank you, now it works. How can I accept this answer?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.