Qt Installer framework linux, how to copy(or extract) 4 Qt shared libraries in /usr/local/lib ?



  • Hi,
    I did'nt found how to copy(or extract) 4 Qt shared libraries that are in a second component of my installer in /usr/local/lib.
    I have a first component with my app and the second component with the 4 Qt shared libraries.I am under linux and use the qt installer framework.
    Has someone an idea ?



  • I have tried that :

    function Component()
    {
    component.addOperation("Copy", "libQt5Core.so.5", "/usr/local/lib/libQt5Core.so.5");
        component.addOperation("Copy", "libQt5Gui.so.5", "/usr/local/lib/libQt5Gui.so.5");
        component.addOperation("Copy", "libQt5Network.so.5", "/usr/local/lib/libQt5Network.so.5");
        component.addOperation("Copy", "libQt5Widgets.so.5", "/usr/local/lib/libQt5Widgets.so.5");
    }
    

    and

    function Component()
    {
        component.addOperation("Extract", "libQt5Core.so.5", "/usr/local/lib/");
        component.addOperation("Extract", "libQt5Gui.so.5", "/usr/local/lib/");
        component.addOperation("Extract", "libQt5Network.so.5", "/usr/local/lib/");
        component.addOperation("Extract", "libQt5Widgets.so.5", "/usr/local/lib/");
    } 
    

    in a script but it is not ok.with the copy instruction I had an error messagebox that the source file doesn't exist...



  • Instead of copying the shared libraries in /usr/local/lib I have tried that too in the script :

    function Component()
    {
        component.addOperation("EnvironmentVariable","LD_LIBRARY_PATH","@TargetDir@/Dirappname:$LD_LIBRARY_PATH");
    } 
    
    
    

    but LD_LIBRARY_PATH is empty if I do echo on it.



  • I have solved this problem by watching the example modifyextract...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.