Qt Quick 3d with the SDK?



  • I am having a bit of trouble getting Qt3d to compile with the current SDK on Ubuntu 10.10.

    I have downloaded the Qt3d preview that is mentioned in the "Labs blog post":http://labs.qt.nokia.com/2011/05/20/qt-quick-3d-downloads-available/ and tried to compile it in Qt Creator (2.2).

    When I try to build it I get this as output:

    @
    Running build steps for project quick3d...
    Configuration unchanged, skipping qmake step.
    Starting: "/usr/bin/make" -w
    make: Entering directory /home/sam/Documents/Programming/Qt/qt3d/quick3d-shadow' cd src/ && /usr/bin/make -f Makefile make[1]: Entering directory/home/sam/Documents/Programming/Qt/qt3d/quick3d-shadow/src'
    cd threed/ && /usr/bin/make -f Makefile
    make[2]: Entering directory /home/sam/Documents/Programming/Qt/qt3d/quick3d-shadow/src/threed' cp -f ../../../qt-quick3d/src/threed/global/qt3dglobal.h /opt/QtSDK/Desktop/Qt/473/gcc/include/Qt3D/qt3dglobal.h cp: cannot create regular file/opt/QtSDK/Desktop/Qt/473/gcc/include/Qt3D/qt3dglobal.h': No such file or directory
    make[2]: Leaving directory /home/sam/Documents/Programming/Qt/qt3d/quick3d-shadow/src/threed' make[1]: Leaving directory/home/sam/Documents/Programming/Qt/qt3d/quick3d-shadow/src'
    make: Leaving directory `/home/sam/Documents/Programming/Qt/qt3d/quick3d-shadow'
    make[2]: *** [/opt/QtSDK/Desktop/Qt/473/gcc/include/Qt3D/qt3dglobal.h] Error 1
    make[1]: *** [sub-threed-make_default-ordered] Error 2
    make: *** [sub-src-make_default-ordered] Error 2
    The process "/usr/bin/make" exited with code 2.
    Error while building project quick3d (target: Desktop)
    When executing build step 'Make'
    @

    Do I need to be recompiling the rest of Qt as well, or is there something I am missing.


  • Moderators

    That is the install step, isen't it?

    You will need root permissions to write into /opt. Try "sudo make install".



  • You can install the SDK in your home folder to skip this kind of issues :)



  • Thanks Tobias. Running the build as root worked. I knew it would be a simple solution.

    I think the confusion was from the instructions saying not to run make install as root if you're building Qt itself for Qt/3d. I must've been tired when I read them the first time.

    The demos all look pretty good now I've got things running. I can't wait to get stuck in.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.