Error building Qt 5.5.1 with Mingw32 under Windows7 32



  • I've got error very similar to described here:
    https://forum.qt.io/topic/50941/solved-problem-installing-qwt-6-1-2-in-qt-5-40/5
    http://forum.qt.io/topic/53530/qt-source-build-win7-uic-exe-not-found
    Right now I have no access to the build system, but can describe the situation.
    I use Qt 4.x environment and mingw32-make. After some time of build process following happened:
    First came warning from Cygwin (by the way why Cygwin here? I don't use it) about DOS-style path. Then I noticed wrong path of the concatenation the two paths: Unix-slashed and DOS-slashes.
    Finally I have got the error: uic.exe not found.

    Is there any gracious way to pass through it not replacing paths (in Makefiles or other generated files)?
    Such as presetting some variables or options?

    PS I mention those two wrong style source and build-destination paths are set by configure (in my case I build to the "build" subdirectory.
    Are there any options or variables to set them manually? Suppose it may solve the problem: I can change them to the same but with right slashes.



  • I made mistake. I use Qt 5.5.1 command-line environment (not 4.x as I wrote before).
    The file D:\qt-everywhere-opensource-src-5.5.1\build\qtbase\bin\uic.exe exists.
    The last output from mingw32-make below:
    ...
    mingw32-make[3]: Leaving directory 'D:/qt-everywhere-opensource-src-5.5.1/build/
    qtbase/src/tools/uic'
    cd widgets/ && ( test -e Makefile || D:/qt-everywhere-opensource-src-5.5.1/build
    /qtbase/bin/qmake.exe D:/qt-everywhere-opensource-src-5.5.1/qtbase/src/widgets/w
    idgets.pro -o Makefile ) && D:/Qt5.5.1/Tools/mingw492_32/bin/mingw32-make -f Mak
    efile
    mingw32-make[3]: Entering directory 'D:/qt-everywhere-opensource-src-5.5.1/build
    /qtbase/src/widgets'
    D:/Qt5.5.1/Tools/mingw492_32/bin/mingw32-make -f Makefile.Debug all
    mingw32-make[4]: Entering directory 'D:/qt-everywhere-opensource-src-5.5.1/build
    /qtbase/src/widgets'
    QT_PLUGIN_PATH=/D/qt-everywhere-opensource-src-5.5.1/build/qtbase/plugins PATH=/
    D/qt-everywhere-opensource-src-5.5.1/build/qtbase/lib${PATH:+:$PATH} 'D:\qt-ever
    ywhere-opensource-src-5.5.1\build\qtbase\bin\uic.exe' D:/qt-everywhere-opensourc
    e-src-5.5.1/qtbase/src/widgets/dialogs/qfiledialog.ui -o .uic/ui_qfiledialog.h
    cygwin warning:
    MS-DOS style path detected: /D/qt-everywhere-opensource-src-5.5.1/build/qtbase
    /lib/D:\qt-everywhere-opensource-src-5.5.1\build\qtbase\bin\uic.exe
    Preferred POSIX equivalent is: /D/qt-everywhere-opensource-src-5.5.1/build/qtb
    ase/lib/D:/qt-everywhere-opensource-src-5.5.1/build/qtbase/bin/uic.exe
    CYGWIN environment variable option "nodosfilewarning" turns off this warning.
    Consult the user's guide for more details about POSIX paths:
    http://cygwin.com/cygwin-ug-net/using.html#using-pathnames
    /usr/bin/sh: D:\qt-everywhere-opensource-src-5.5.1\build\qtbase\bin\uic.exe: com
    mand not found
    Makefile.Debug:2901: recipe for target '.uic/ui_qfiledialog.h' failed
    mingw32-make[4]: *** [.uic/ui_qfiledialog.h] Error 127
    mingw32-make[4]: Leaving directory 'D:/qt-everywhere-opensource-src-5.5.1/build/
    qtbase/src/widgets'
    Makefile:38: recipe for target 'debug-all' failed
    mingw32-make[3]: *** [debug-all] Error 2
    mingw32-make[3]: Leaving directory 'D:/qt-everywhere-opensource-src-5.5.1/build/
    qtbase/src/widgets'
    Makefile:520: recipe for target 'sub-widgets-make_first' failed
    mingw32-make[2]: *** [sub-widgets-make_first] Error 2
    mingw32-make[2]: Leaving directory 'D:/qt-everywhere-opensource-src-5.5.1/build/
    qtbase/src'
    Makefile:41: recipe for target 'sub-src-make_first' failed
    mingw32-make[1]: *** [sub-src-make_first] Error 2
    mingw32-make[1]: Leaving directory 'D:/qt-everywhere-opensource-src-5.5.1/build/
    qtbase'
    makefile:68: recipe for target 'module-qtbase-make_first' failed
    mingw32-make: *** [module-qtbase-make_first] Error 2

    D:\qt-everywhere-opensource-src-5.5.1\build>

    the



  • The problem with test.exe SOLVED. It happened because the same tool in Cygwin. To build I remove cygwin from PATH and add the path to MSYS/bin directory with test.exe (it was not in PATH!)
    I am sure this sould be well documented because a lot of MinGW developers have also Cygwin installed.

    During building the Qt I've also passed through a lot of problems:

    1. I've got “Project ERROR: Unknown module(s) in QT: quick” in examples. Don't investigate this, just turn off the examples. If this is because of no OpenGL the case should be auto-configured more gracefully.

    2. Two functions was undefined:
      https://forum.qt.io/topic/62864/qt-5-5-1-build-error
      Can anyone comment?

    3. I was affected by error: https://forum.qt.io/topic/32792/qt5-build-on-windows-with-mingw-off64_t-error-solved

    4. I was affected by error described here: https://bugreports.qt.io/browse/QTBUG-31141
      (I deleted qttools and restart mingw32-make again to pass through)

    5. I was unable to find the information what version of Perl and Ruby are to be used or/and are recommended to build specific versions of Qt. In my case I was unable to build qtwebkit using the latest Active Perl and the Strawberry Perl (perhaps because of wrong slashes in some pathes), but using some old perl (from some old Qt distribution) I succeeded.
      I used:
      perl -v
      This is perl, v5.8.8 built for msys-64int
      Copyright 1987-2006, Larry Wall

    6. Finally the build finished and I install Qt without error messages.
      But during reconfiguration of my project in Qt Creator 3.5.1 with new Qt. There is no qmlscene.exe file in my build! I passed through by copy it from pre-build Qt (although this tool seems not working in new place).
      Can anyone comment this?

    7. The worse thing for me:
      Although I build-in OpenSSL the tests shows that my binary executable cannot make HTTPS connections from Windows XP sp2 (32). It can from Windows 7 (both 32 and 64 bit). No any error messages appear.
      To make HTTPS work everywhere was my primary reason to rebuild Qt from source. So what I have to do with it? How I can get know the reason and fix it??

    PS My configuration command:
    ../configure -nomake examples -largefile -opensource -confirm-license -no-opengl -no-angle -no-openvg -qt-pcre -no-nis -openssl-linked OPENSSL_LIBS="-L d:/openssl102e/lib -lssl -lcrypto -lws2_32 -lgdi32" -I "d:/openssl102e/include" -L "d:/openssl102e/lib" -prefix d:/Qt5.5.1ssl



  • Hi shestero,

    for me the question is: What are you trying to achieve?

    To have a finished compiled Qt 5.5.1 with no other additions than the "normal" version - why not downloading the original installer? ;D
    http://download.qt.io/official_releases/qt/5.5/5.5.1/qt-opensource-windows-x86-mingw492-5.5.1.exe

    Kind regards,
    Pixtar



  • Sorry for a long reply. In my case I wanted to build-in OpenSSL. Because under some system the HTTPS was not working. DLLs don't help. This is wide spread problem. By the way after much ado I successfuly built Qt 5.5.1 with MinGW32 and build-in OpenSSL but HTTPS from my application still magically don't work under one ancient MS Windows XP sp2. It's unknown how to solve it. The only hint (suspection) that the system dll has no "VCRT security extension" that is now standart.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.