Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

final link failed: Nonrepresentable section on output



  • Hello,

    I am trying to build QT 5.2.0 for embedded device (Cross compiling).
    During, sudo make it flashes this error, try ed some turn arounds to the file

    ./qtdeclarative/src/qml/qml.pro 
    

    but still flashing error.

    libQt5Qml.so.5.2.0: hidden symbol `void QQmlThread::postMethodToThread<QQmlDataBlob*, QQmlDataBlob*, QQmlDataLoaderThread>(void (QQmlDataLoaderThread::*)(QQmlDataBlob*), QQmlDataBlob* const&)' isn't defined
    /usr/local/angstrom/arm/lib/gcc/arm-angstrom-linux-gnueabi/4.3.3/../../../../arm-angstrom-linux-gnueabi/bin/ld: final link failed: Nonrepresentable section on output
    collect2: ld returned 1 exit status
    make[3]: *** [../../lib/libQt5Qml.so.5.2.0] Error 1
    make[3]: Leaving directory `/home/mars/qt-5.2-host/qtdeclarative/src/qml'
    make[2]: *** [sub-qml-make_first-ordered] Error 2
    make[2]: Leaving directory `/home/mars/qt-5.2-host/qtdeclarative/src'
    make[1]: *** [sub-src-make_first] Error 2
    make[1]: Leaving directory `/home/mars/qt-5.2-host/qtdeclarative'
    make: *** [module-qtdeclarative-make_first] Error 2
    
    

    Any idea to solve this error.

    Thank you
    Answers Appriciated



  • Hello,

    I added this line in

    /qtdeclarative/src/qml/qml.pro
    

    Still it's flashing errors.

    QMAKE_CXXFLAGS_RELEASE += -fno-inline
    

    Any other turnarounds?

    Thank you



  • I cleaned everything, added all the turnarounds, after many attempts able to build Qt. With **-nomake examples and ** and some other options.

    Any turnarounds to build examples.

    Thank you,



  • Hi, I ran into this problem too, I can't build qt because I get this same error.

    How did you solve the problem? What configuration are you using beside -nomake examples?

    Thanks,


Log in to reply