Problem in creating SIS Package



  • I was trying to create SIS Package with Publish Project wizard of QT, and I got this error during the process..

    bq. C:\QtSDK\Symbian\SDKs\Symbian3Qt473\epoc32\tools\make.exe: *** No rule to make target D:/Qt', needed bybld.inf'. Stop.
    Sis file not created due to previous errors

    What does this mean?

    " I do have 4 warnings while building the project"


  • Moderators

    Have you considered to "file a bug report":http://bugreports.qt.nokia.com/?

    Which version of Qt Creator are you using?



  • [quote author="Tobias Hunger" date="1306390853"]Have you considered to "file a bug report":http://bugreports.qt.nokia.com/?

    [/quote]
    No, I haven't... I do now..

    [quote]Which version of Qt Creator are you using?[/quote]

    Qt Creator 2.2.0
    Based on Qt 4.7.4 (32 bit)

    " I left the Unique app ID to the default"
    Is it has something to do with the problem?


  • Moderators

    No idea. So far I did not look into the publisher code:-)



  • I have two warnings while I tried to deploy the project..

    bq. :-1: warning: The Symbian tool chain does not handle spaces in the project path '/Qt Projects/First_Mobile_App'.
    :-1: warning: The Symbian tool chain does not handle special characters in the project name 'First_Mobile_App.pro' well.


  • Moderators

    So fix those! The first one is most likely causing your issue.



  • [quote author="Tobias Hunger" date="1306396259"]So fix those! The first one is most likely causing your issue.[/quote]

    I have 33.4 GB free space in that partition



  • [quote author="Tobias Hunger" date="1306396259"]So fix those! The first one is most likely causing your issue.[/quote]

    Hi Dinesh Balu,

    You could also post your pro file and we might give you some hints.

    [quote author="Dinesh Balu" date="1306391199"]
    Qt Creator 2.2.0
    Based on Qt 4.7.4 (32 bit)
    [/quote]

    Btw how did you install Qt Creator? For development of Qt applications for Symbian you should have appropriate SDK that are bundled in "Qt SDK 1.1":http://qt.nokia.com/downloads

    Best regards,
    Leon



  • [quote author="leon.anavi" date="1306396636"]

    Hi Dinesh Balu,

    You could also post your pro file and we might give you some hints.

    [/quote]

    k Leon... here it is...

    @# Add files and directories to ship with the application

    by adapting the examples below.

    file1.source = myfile

    dir1.source = mydir

    DEPLOYMENTFOLDERS = # file1 dir1

    symbian:TARGET.UID3 = 0xE56FC4D1

    Smart Installer package's UID

    This UID is from the protected range

    and therefore the package will fail to install if self-signed

    By default qmake uses the unprotected range value if unprotected UID is defined for the application

    and 0x2002CCCF value if protected UID is given to the application

    #symbian:DEPLOYMENT.installer_header = 0x2002CCCF

    Allow network access on Symbian

    symbian {
    TARGET.CAPABILITY += NetworkServices

    vendorinfo = "%{\"FundooLoops\"}" ":\"FundooLoops\""
    

    }

    If your application uses the Qt Mobility libraries, uncomment

    the following lines and add the respective components to the

    MOBILITY variable.

    CONFIG += mobility

    MOBILITY +=

    QT +=opengl
    SOURCES += main.cpp
    gameplay.cpp
    HEADERS +=
    gameplay.h
    FORMS +=

    Please do not modify the following two lines. Required for deployment.

    include(deployment.pri)
    qtcAddDeployment()

    OTHER_FILES +=
    qtc_packaging/debian_fremantle/rules
    qtc_packaging/debian_fremantle/README
    qtc_packaging/debian_fremantle/copyright
    qtc_packaging/debian_fremantle/control
    qtc_packaging/debian_fremantle/compat
    qtc_packaging/debian_fremantle/changelog@

    [quote author="leon.anavi" date="1306396636"]

    Btw how did you install Qt Creator? For development of Qt applications for Symbian you should have appropriate SDK that are bundled in "Qt SDK 1.1":http://qt.nokia.com/downloads

    [/quote]

    Yeah Leon, I got that SDK from the same link..



  • [quote author="Dinesh Balu" date="1306395975"]I have two warnings while I tried to deploy the project..

    bq. :-1: warning: The Symbian tool chain does not handle spaces in the project path '/Qt Projects/First_Mobile_App'.
    :-1: warning: The Symbian tool chain does not handle special characters in the project name 'First_Mobile_App.pro' well.[/quote]

    Make sure your project path has no spaces at first. :)
    It's recommended



  • [quote author="Chuck.Gao" date="1306401138"]

    Make sure your project path has no spaces at first. :)
    It's recommended[/quote]

    Yeah I have more free space..... how much disk space it's gonna need?



  • no, not free space of your disk. I mean, the spaces in your path. It's recommended to use "d:/QtProjects" instead of "d:/Qt Projects".



  • [quote author="Chuck.Gao" date="1306403823"]no, not free space of your disk. I mean, the spaces in your path. It's recommended to use "d:/QtProjects" instead of "d:/Qt Projects".[/quote]

    Oh... yeah.... It's "Qt Projects"... I rename it now... :)



  • I change it then it said that
    "The Symbian SDK and the project must be in the same drive"

    SO I move the Project directory to the C drive

    Now it shows 14 warnings and 1 error

    Some of them is....

    @:-1: warning: Can't find following headers in System Include Path
    :-1: <GLES2\gl2.h>
    :-1: (Sys Inc Paths "\QtSDK\Symbian\SDKs\Symbian1Qt473\include\QtCore" "\QtSDK\Symbian\SDKs\Symbian1Qt473\include\QtCore\tmp" "\QtSDK\Symbian\SDKs\Symbian1Qt473\include\QtGui" "\QtSDK\Symbian\SDKs\Symbian1Qt473\include\QtGui\tmp" "\QtSDK\Symbian\SDKs\Symbian1Qt473\include\QtOpenGL" "\QtSDK\Symbian\SDKs\Symbian1Qt473\include\QtOpenGL\tmp" "\QtSDK\Symbian\SDKs\Symbian1Qt473\include" "\QtSDK\Symbian\SDKs\Symbian1Qt473\include\tmp" "\QtSDK\Symbian\SDKs\Symbian1Qt473\mkspecs\common\symbian" "\QtSDK\Symbian\SDKs\Symbian1Qt473\mkspecs\common\symbian\tmp" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\osextensions\stdapis" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\osextensions\stdapis\sys" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\stdapis" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\stdapis\sys" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\osextensions\stdapis\stlport" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\stdapis\stlport" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\oem" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\middleware" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\domain\middleware" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\osextensions" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\domain\osextensions" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\domain\osextensions\loc" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\domain\middleware\loc" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\domain\osextensions\loc\sc" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\domain\middleware\loc\sc" "\QtProjects\FirstMobileApp\moc" "\QtProjects\FirstMobileApp\moc\tmp" "\QtProjects\FirstMobileApp" "\QtProjects\FirstMobileApp\tmp" "\QtProjects\FirstMobileApp\ui" "\QtProjects\FirstMobileApp\ui\tmp" "\QtSDK\Symbian\SDKs\Symbian1Qt473\epoc32\include\variant" "c:/qtsdk/symbian/tools/gcce4/lib/gcc/arm-none-symbianelf/4.4.1/include")
    :-1: Dependency list for "\QtProjects\FirstMobileApp\main.cpp" may be incomplete@



  • Should I use Nokia's Smart Installer.....
    How to use it?



  • Got it....

    I made a simple app and built the sis file and done successfully...

    The Problem occurs only when I built a app with OpenGL support...
    It's like openGL is not supported... It says all the terms of openGL like GL_MODELVIEW as undefined..



  • The Main Error is

    bq. \QtSDK\Symbian\SDKs\Symbian1Qt473\include\QtOpenGL\qgl.h:69: error: GLES2/gl2.h: No such file or directory



  • podrías explicar como solucionaste tu problema, me encuentro con el mismo problema no e logrado arreglarlo.


  • Moderators

    Hi dannybarreto,

    Welcome to devnet!

    Could you translate your question to english please? That way more people can understand it and can help you solve your problem.



  • bq. Got it….
    I made a simple app and built the sis file and done successfully…
    The Problem occurs only when I built a app with OpenGL support…
    It’s like openGL is not supported… It says all the terms of openGL like GL_MODELVIEW as undefined

    could explain how solve your problem, I encounter the same problem and managed to fix it.


  • Moderators

    Ok, that's even better.

    Could you explain how you solved it?



  • Hi, I have the same problem, when I add openGL to my project, the project doesn't work on symbian?

    because of this in my .pro

    @QT += opengl@

    I get this error

    @/QtSDK/Symbian/SDKs/Symbian1Qt473/include/QtOpenGL/qgl.h:69: fatal error: GLES2/gl2.h: No such file or directory
    @

    Qt 4.7.4

    It works on Maemo N900, and in Simulator, but not in Symbian!!


    I just solved this issue, it's not supported on Symbian^1, so remove Symbian^1 target,

    On left click on projects, then symbian->build,

    Near Edit build config, remove all Symbian^1 related stuff.

    Qt Version, select one for Symbian^3.

    then, build and enjoy.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.