Important: Please read the Qt Code of Conduct -

Qt assistant

  • I feel dumb for asking this but I lost my Qt assistant after I uninstalled the Qt library to replace it with sdk. My question is where can I download Qt assistant without having to download the Qt library. Thanks in advance.

  • You uninstalled qt library.
    Then you installed the sdk? So qt assistant should be there.

    Did you search your system for the qt assistant executable? What is your Os?

  • Hi all,
    sorry to break in this thread, but i have the same "problem".
    After deleting the old and installling the new sdk, assistant doesnt work anymore.
    The binaire is precent, but doesnt react when running it.
    I'm working at a linux distro. Ubuntu 10.4.
    I work around it using creator for reading the docs.

  • I ended up reinstalling the Qt library to get assistant back. I had leftover files in my Qt library folder that I found which had vs2008 projects in there was a assistant project. I tried to build it but could not get it to work. Thanks for the reply.

  • Same scenario, but on Windows 7 64.

    Had Qt installed, removed and installed Qt SDK. Now the assistant executable is present but loads without any content.

  • Moderators

    If I remember well, Qt Assistant is not being installed by default. Check in Qt SDK Maintenance Tool, whether you have Assistant included in your installation - if not, just check the box, wait for it to install, and use it :)

  • Actually, I had over-ridden the default option. The problem is that it installed without any link in the start menu or references to the documentation files.


    locate the correct "assistant.exe" in your install directory. ("C:\Qt\Desktop\Qt\4.7.4\mingw" for me)

    Run it, and go to "Edit" menu > "Preferences..." > "Documentation" tab > "Add..."

    Select all the ".qch" files in your documentation folder (In my case "C:\Qt\Documentation"

    Click "Open", then "OK"

    Additionally, in Windows 7 you'll have to choose to pin the correct assistant.exe to the start menu (or link to it somewhere) as it doesn't get created as a link, even if you asked it to be installed!

  • Hmmm... I'm having a similar problem with the 4.8 libraries under Mac OS X Snow Leopard (10.6.8). Assistant and Designer have stopped working since I installed the 4.8 libraries. Clicking the icons on the Dock causes them to bounce but nothing else happens. I ran /Developer/Applications/Qt/ manually and got the following error message:

    dyld: Symbol not found: _kCFWebServicesProviderDefaultDisplayNameKey
    Referenced from: /Library/Frameworks/QtWebKit.framework/Versions/4/QtWebKit
    Expected in: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    Trace/BPT trap

    As far as I can remember I've never installed the SDK so I wasn't expecting to have to install it this time. Can anyone shed any light on this or tell me where to download Assistant & Designer?



  • Ah-ha! I've just found a bug report #QTBUG-23157 which seems to indicate that the binaries of tools like Assistant & Designer will only work under Lion (10.7.x) so I'm stymied until I can upgrade to Lion which I can't at the moment until a certain piece of software is built to run without the PPC emulator. Back to 4.7 libraries... (if I can find them).

Log in to reply