Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt5.6.0 build fails



  • Hello,
    I'm trying to build Qt5.6.0 beta on Ubuntu 15.10 and on Raspberry PI2 but they both fail on the same problems:

    1. undefined reference to z_inflateInit_ , z_inflateEnd, etc.
      inflateInit & Co are in the zlib lib but where are the z_.... versions, I tried to install all 'zlib' relate packages, compiled zlib 1.2.8 from sources, no way...
    2. QtWebEngine stops on missing 'xscrnsaver' dependency, again where is 'xscrnsaver' ? I can find of course 'xscreensaver' packages but no 'xscrnsaver'....
      Thanks,
      J.


  • dunno if it is still important for you, but i stumbled upon the same problem some time ago. so just for others which may search for a solution, even if this is a really old issue. the needed package on debian/ubuntu distributions is called libxss-dev.



  • For the zlib problems, check your config.summary (in qtbase) to see which zlib it's trying to use - if you don't install the zlib dev package, you might just want to use "configure -qt-zlib" to use the bundled copy of zlib.


Log in to reply