Qt program fails to run



  • I'm starting to learn c++ gui and thought I would create the first gui program but it doesn't seem to run. I created a project and edited it in Qt designer. When I attempt to run it, qtmake.exe ask permissions to use internet access through my firewall which I allow. As soon as that happens, in the right lower corner of the screen a build progress bar pops up and progress is at 50%. Then everything freezes.

    When I attempted to click the start debugging instead of run, after 40 seconds a message pops up stating that the progress toke longer than expected and I can choose either to give GDB more time or stop debugging. If I choose to continue, nothing happens.

    I also tried

    build > run qmake

    build > rebuild project "test"

    which ran successfully.

    I then went to the release folder of the project and double clicked test.exe (28k). In Windows task manager, 3 copies of test.exe were created. Each is 112k in size. For 30 minutes the application didn't start while the mouse cursor seemed to be loading. Then the size of the 3 copies of test.exe in Windows task manager started to change from 112 to 56 to 60.

    Any suggestions?


  • Qt Champions 2016

    Hi and welcome
    Do you by any chance have Avast running or any virus scanner
    that might intercept new exe files?

    Ps. you cannot click on exe as it needs some DLLS.



  • Thank you for taking the time to reply!

    Yes, I have Avast running.


  • Qt Champions 2016

    @WhatIf
    Ok. try to disable it for test.
    I have seen it makes issues when trying to build and run.



  • Is this problem with Avast only or all other antivirus software?

    Can I give Qt or test.exe privileges from Avast to allow the program to run instead of disabling Avast?


  • Qt Champions 2016

    @WhatIf
    Some other also do. Its a bit random. I have avast too. never happened.
    Just disable to test. if it then works, then you can add your build folder location to exceptions
    and it should work.
    Im not suggesting to just turn it off for good :)

    If you make a folder in say c:\builds and change default path to
    c:/builds/build-%{CurrentProject:Name}-%{CurrentKit:FileSystemName}-%{CurrentBuild:Name}
    then add c:/builds to Avast. It should stop checking/blocking.

    Setting default build path:
    Menu Tools->Options->Build & run. Then in bottom of window, there is
    build path.



  • @mrjj

    Disabling Avast got it to work.

    Thanks :)


  • Qt Champions 2016

    @WhatIf
    super. so you can add build folder to exclusion list and it should work too


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.