SDKMaintenanceTool missing. Everything else seems okay. Win32.



  • I installed SDK 1.1.1 today (May23) for win32/mingw and projects build and run okay with the new tools. But when I go to QtCreator\Help\Start Updater nothing happens. There's a link in the start menu but it won't run, complaining that the pointed-to program does not exist. Unfortunately, I clicked the item that says delete the bad link.

    Can I just download SDKMaintenanceTool.exe from somewhere without going through the whole big install?

    I did find SDKMaintenanceTool.exe.org in the root of the installation, and renamed a copy of it, but it seems to want to install everything....

    So I put a copy in C:\QtSDK\Desktop\Qt\4.7.3\mingw\bin\SDKMaintenanceTool.exe and QtCreator seemed to find it. Solved?

    Is that how it's supposed to work?



  • I can confirm similar behavior:
    I was using SDK 1.0 ( or maybe it was 1.1 RC ) then I updated to 1.1 stable using SDKMaintenanceTool and now I don't have SDKMaintenanceTool in the root directory of QtSDK (and QtCreator's 'Start Updater' doesn't work).

    I suppose it is some kind of bug (if you have time, you can post a bug report).

    I would love to have only the exe and not to reinstall everything.

    ( I'm using Windows 7 64bit. )



  • Sorry guys this is one of our biggest problem in the current installer: bad to reproduce and a fix as a rewrite of one part of the installer is in progress, but it takes some time for this huge change inside the installer framework code(vote/watch here: http://bugreports.qt.nokia.com/browse/QTSDK-159).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.