pi 2 trying to buid/run 5.5.x and can't find qtcreator on wheezy



  • Made the mistake of "apt-get install qt" and everything downloaded and installed just fine. However, what was in the repository is Qt 4.x.
    I wish to use 5.5.x so tried a git download from the "official" qt sources. Following qt.io directions, almost everything compiled (the ones that didn't were known limits on Pi 2 so no worries.) Compilation was run natively on the Pi 2, not cross-compiled, with swap file delegated to external USB drive with 1Gb swap file size, and took less than 12 hours.
    However, no qtcreator source appears in the qt5 directory whatsoever.

    Could the qtcreater, version 2.5.0 that came from debian's repository be overriding the 5.5.x distribution?

    How do I get 5.5.x COMPLETE qt on the Pi 2, please?

    And, I keep getting 'set locale' errors but don't care because I don't want the code bloat anyway. Unless it is critical to building qt.


  • Lifetime Qt Champion

    Hi,

    Qt Creator is not part of Qt the framework sources (never was for that matter).

    You can clone it from here separately and built it with your freshly built Qt.



  • Can you tell me how to do that, please? I can't tell what to download or how to download it. I don't know how to build it and not even sure my 5.5.x Qt is actually built. There are no indications of how to test that. When I've tried to use Qt before, i always entered through "qtcreator" or (long ago) "qtquick," and so on.

    Since qtcreator is not part of the "framework" (!) it makes me wonder of other extremely important parts of Qt are not included in the "framework." What else are we missing?

    Still a newbie re Qt.
    Don't the RPi2 executables have to be different from the RPi 1?


  • Lifetime Qt Champion

    Just use git to clone the repository. You have the git clone links at the bottom of the page of the repository.

    Qt Creator was created way after Qt started and is independent of the current Qt version. You can build applications with several versions of Qt (4 or 5, maybe even 3) and the same Qt Creator. So you're not missing anything from the framework.

    Since you built Qt 5 natively you also probably called make install at the end. In this case you probably have a folder looking like /user/local/qt5/ and in there a bin folder containing qmake.

    So basically to build Qt Creator

    git clone https://code.qt.io/qt-creator/qt-creator.git
    cd qt-creator
    /path/to/qt5/bin/qmake
    make
    


  • Even after what appeared to be a successful compile of Qt5, whereis only shows 2 qmakes, one in /usr/bin and the other in /usr/bin/X11, where both give a version 2.01a, using Qt version 4.8.2.

    This is so <censored> <censored> frustrating.

    I want version 4 completely GONE and version 5 fully functional. I've gone over dozens of web pages in the past two weeks, tried downloading qt5 from qt.io, and STILL can't get qmake of qt5, and can't get qtcreator 3.x.x to compile.

    Qt BETTER be worth all this trouble. There are many competing IDE's and I'm about to give up on Qt altogether. Why is this SO freaking difficult???

    It appears I won't be able to recommend adopting Qt.


  • Lifetime Qt Champion

    If you want to remove Qt 4 completely just call "apt-get remove *qt4*". Note that it's not a Qt problem but the distribution handling.

    After building Qt 5 did you call make install ?

    [edit: fixed eaten stars… SGaist]



  • Thank you for the method for removing v4.
    Yes, I did make install. But there was no qmake, no qt-creator (loaded later,) and no qtquick, etc.
    Qt-creator will not compile, will not qmake, will not make.
    It is NUTS to make such a wonderful system so difficult to set up.


  • Lifetime Qt Champion

    Can you show the steps you used to build Qt 5 ? Options you gave, summary of configuration etc.



  • Instructions used THIS time come from:
    https://wiki.qt.io/Building-Qt-5-from-Git -- which really boil down to these steps:

    1. $ git clone git://code.qt.io/qt/qt5.git
    2. $ cd qt5
    3. $ git checkout 5.5
    4. $ cd qt5
    5. $ perl init-repository
    6. $ cd qt5
    7. $ git checkout v5.5.0 (which didn't work)
    8. $ ./configure -developer-build -opensource -nomake examples -nomake tests
    9. $ make -j4 --- which breaks with lots and lots and lots and lots and lots and lots of errors. see below.

    If you run 'make' again and again, more modules get compiled but it eventually completely breaks with the output below.
    No "qmake" ever shows up or gets compiled anywhere, no useful environment in evidence for Qt 5x. I'm about fed up with compiling Qt from git OR from qt.io.

    Here is the output (tail) of "make -j4" again:

    /usr/bin/ld: cannot find -lQt5Core
    collect2: ld returned 1 exit status
    Makefile:530: recipe for target '../../lib/libQt5Network..5.6.0' failed
    make[3]: *** [../../lib/libQt5Network..5.6.0] Error 1
    make[3]: Leaving directory '/root/opt/qt5/qtbase/src/network'
    Makefile:219: recipe for target 'sub-network-make_first' failed
    make[2]: *** [sub-network-make_first] Error 2
    make[2]: Leaving directory '/root/opt/qt5/qtbase/src'
    Makefile:45: recipe for target 'sub-src-make_first' failed
    make[1]: *** [sub-src-make_first] Error 2
    make[1]: Leaving directory '/root/opt/qt5/qtbase'
    Makefile:73: recipe for target 'module-qtbase-make_first' failed
    make: *** [module-qtbase-make_first] Error 2
    root@rpi2U2:~/opt/qt5#


  • Lifetime Qt Champion

    Something strange here you should have 5.5 but building 5.6.

    What exact error did you get when checking out the tag ?



  • I don't know the phrase "checking out the tag." However, no errors came up when downloading from git or qt.io.


  • Lifetime Qt Champion

    git checkout v5.5.0 v5.5.0 is a tag



  • Ok, tried that "check out," then ran make again, with identical results.
    Btw, your "apt-get remove qt4" did not work. Nor did qt4.



  • I have no idea how 5.6.x got in the mix. <sigh>
    Maybe Qt is not ready for prime time. It's only 20+ years old, so maybe someday...


  • Lifetime Qt Champion

    Because it was *qt4* but the forum ate the stars…

    That's because your checkout failed so you got the current branch which is 5.6. IIRC You can get 5.5 by passing --branch 5.5 to init-repository



  • Is there a way to force 5.5 during make?


  • Lifetime Qt Champion

    No, you have to check out 5.5 before calling make



  • Yes, I did that and yet it still tries to make 5.6.x versions of code.


  • Lifetime Qt Champion

    Did you checkout using init-repository ? Otherwise you may have the modules still at 5.6


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.