Qt SDK Installation Download Error



  • Hi,

    I am trying to install the Qt SDK. I have downloaded the LGPL Qt SDK for Windows. I run the installer, select the default installation, and click Install. The installation runs for about one minute, gets to the Symbian Development files, and stops. There is no network utilization for a few minutes, and then the connection times out and an error is displayed. Here is a screenshot:

    !http://joel.topwebsnetwork.com/Qt_Installation_Error.png(Installation Error)!

    I have run the installer at least 10 times, and it never works. I am running Windows 7, and I have plenty of free space on my hard disk and RAM.

    This has had me stumped for hours. Any help will be appreciated.

    Thanks.


  • Moderators

    I know this is not a solution but anyway, I did exactly the same thing yesterday on windows7 64 bit.
    So the files must be ok.

    maybe a connection error?



  • I agree, I think it is a connection problem. I have tried with a wireless connection and a cable connection. I have also re-started my computer. Nothing works.

    By the way, it doesn't always stop on "Symbian Development Files". Sometimes it stops at "MinGW 4.4" or another place, but it never gets past about 5%.


  • Moderators

    I had that too. What if you wait just a while longer and retry again, wait and retry again?

    What download speed do you have?
    Did you have previous qt version installed? I had qt4.7.0 on mine.



  • I have tried clicking "Retry" multiple times, but it is always the same.

    My wireless connection is 54 Mbps, and my LAN is 100 Mbps.

    No, there is not previous Qt installed. I am installing Qt for the first time on this computer.



  • You can download the offline SDK from "here":http://labs.qt.nokia.com/2011/05/04/qt-sdk-1-1-released/, and try that.



  • Thanks. I was looking for some kind of offline installer. I will try this.



  • Some of the older releases installed correctly only with Run as Administrator, but on my system (7 x64) the 1.1 version of SDK installed correctly without that - but if you have still have errors you can also try that.



  • I downloaded the offline installer, and double-clicked on it to run it. The normal warning "The publisher could not be verified. Are you sure you want to run this software?" pops up, and I click "Run". But nothing happens. The task manager shows that no Qt processes are running.

    I am beginning to think that this is a problem with my computer, or maybe with my firewall. I will try disabling my firewall temporarily.



  • Firewall should have no interference with the offline installer, maybe the firewall caused the online installer failures, but for the offline version only the antivirus has work to do (so you can try to temporary disable the virus shield).

    Are you sure that there is no process running? Because this couple of minutes waiting period after the double-click is normal behavior - the installer is compressed and it has to decompress some files before it can start.



  • Yeah, I completely turned off my anti-virus (Microsoft Security Essentials), which includes the firewall and the virus shield. I tried running both the online and offline installers, but there is no difference.

    Yes, I had to wait for about 1 minute while my computer was busy. Actually, I tried again, and the process pops onto the task manager for about 1 second, and then goes off.

    In response to your earlier post, yes, I have tried to run both installers with "Run as Administrator", but to no avail.

    I am sure that this is a problem with my computer. The question is how to fix it.



  • I found out what was the problem. Another program was blocking the Qt Installation files from being downloaded/run. I disabled that program, and I was able to install Qt.

    Thanks for helping me troubleshoot this issue.


  • Moderators

    I'm glad you solved it.

    It could be interesting for others (and myself) to know what kind of program blocked it and how did you find out it was blocking qt installation.



  • Well, my computer is running on a network in a workplace, and the network administrator had installed a program called NetNanny that monitors our internet activity. For some reason, it was blocking the online installer from downloading the necessary files. I contacted the network administrator, and asked him to make an exception for the installers. After he made the exception, out of curiosity, I tried the offline installer, but it still didn't run. Then I tried the online installer, and it ran fine.

    I still don't know what the problem was with the offline installer. Perhaps 1.5 Gb was too much for my system to handle. Anyways, the problem is solved.

    Thanks again for your help.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.