Example Projects Are Not Response Until CMD + Tab, OS X



  • I'm attempting to build some of the example Qt programs (in particular, hellogl2, although the issue happens with others too) and launch the from the command line on OS X. Strangely, when I launch the programs, they are unresponsive until I command + tab away and back to the application. By unresponsive, I mean they do not respond to keyboard input, mouse input, and I am not able to select any of the menu items. I've tried both Qt4 version 4.7.7 and Qt5 version 5.5.0, on OS X Mavericks, Yosemitie, and El Capitan, and all version combinations and platforms seem to exhibit this behavior. I have not modified the source code for the example programs in any way.

    Is the expected behavior from the example programs? Is there a way to resolve this problem?



  • I am currently using Qt 5.4.0 compiled from source on Yosemite XCode 7.

    I tried to open a program (any program) using the command line and didn't find the problem you describe. I didn't specifically try Qt 5.5.0. I have used Mavericks and Yosemite quite a bit and have not seen this problem. I have used Qt from 4.x.x on OS X with various versions of XCode. I have compiled using makespecs of g++ and xcode. I don't use the precompiled versions of Qt in general.

    From the command line I start the application using 'open':

    open ~/path_of_any_program/bin/name_of_program.app
    

    The application when opened from the command line appears immediately and is automatically in focus. I can interact with it without having to CTRL+Tab or anything else.

    I only open programs from the command line on occasion when it is convenient. It is possible that I simply hadn't noticed this problem before but I am inclined to think there is some other reason (something other than Qt).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.