Qtcreator Debugger does not show QT types



  • I'm new at QT (4.8) and C++. To build the product my team uses a script that runs outside the editor on Unix command line. I tried attaching the QT Creator to a running application for debugging purposes. Breakpoints are hit and I can easily traverse the code using F10, F11.

    But the problem is I can't see any of the content of the variables I am debugging. They all appear to contain members and properties that are not usefull such as "d", "data", "shared_empty". Where is the actual content of the variable? Even a simple Qstring does not show it's content. see image at http://i.stack.imgur.com/oLH8f.png

    The image in the documentation shows a Qstring and its content. http://doc.qt.io/qtcreator/creator-debug-mode.html How come I cannot see it when debugging my code?

    p.s.
    Everybody else in the team long gave up on trying to make this work, and prefer using qDebug - make cycles


  • Qt Champions 2016

    Hi
    Shot in the dark..
    Try to disable "Load system GDB pretty printers"
    in Tools->Options->Debugger->GDB



  • Still the same


  • Qt Champions 2016

    @TWiegner

    Kinda expected it would not help. Looks odd you screenshot.

    So If you make new project in Creator and run (F5) can it then view values?

    Also, the external script that builds the product. Does it include debug information and
    is optimizations on ?

    Also, it fair to assume its the same compiler as Creator is setup to use?



  • @mrjj
    Opening a new Project from within the creator crushes the creator
    Building an existing app fails on :

    Starting: /p/dt/sde/tools/em64t_SLES11/bin/make -w
    itools wrapper: failed to determine version for
    the program named make (/p/dt/sde/tools/em64t_SLES11/bin/make)

    default version /usr/XXX/00r1.3/bin/make does not exist

    previous version(s) <00r1.2:00r1.1:00r1:97r1.7:97r1.6:97r1.5:97r1.4:97r1.3:97r1.2:97r1.1:97r1> also searched

    check your $PROJECT_ITOOLS or $USER_ITOOLS to make
    sure you have a path configured for `make'
    or make points at a tool in /usr/XXX/bin.
    Exited with code 1.
    Error while building project Hello
    When executing build step 'Make'

    I am not sure if the external script has debug information. But I opened the debugger log in creator and saw:
    "The debugging helper library was not found at ."

    Maybe this would help?


  • Qt Champions 2016

    @TWiegner said:

    Well, it does seems that the tool chain for Creator is not as it except as
    you should then be able to create a new project with no errors.
    How did you install it ?

    They discuss "The debugging helper library was not found at ." here
    https://forum.qt.io/topic/22790/when-starting-gdb-with-application-message-debugging-helper-missing-is-displayed-solved/8
    But its for windows.
    I wonder if your issues is simple a "wrong" gdb but Im not sure.
    Also
    http://doc.qt.io/qtcreator/creator-debugging-helpers.html
    Talk about python to be able to view structures so might be that , which are missing.
    It also mentions
    "To force a plain C-like display of structures, select Tools > Options > Debugger > Locals & Expressions, and then deselect the Use Debugging Helper "

    Might try that also.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.