[SOLVED] JSON message object is missing the id property



  • Hi,
    I have a problem with QWebChannel. When I start the Qt 5.5 example "standalone" (Qt WebChannel Standalone Example) and load file:///C:/Qt/5.5/Examples/Qt-5.5/webchannel/build-standalone-Desktop_Qt_5_5_0_MinGW_32bit-Debug/index.html?webChannelBaseUrl=ws://localhost:12345 in web browser (Firefox), I only get a message inside the output box of Qt Creator:

    JSON message object is missing the id property: {
    "type": 3
    }

    Also I tried an own example where the html page is loaded on server (Xampp). The connection between server and client is successful, in each case. But the QObject can not be transfered.
    Does anyone how I could fix this?

    P.S.:
    I forget, there are some outputs before this error message:

    qt.network.ssl: QSslSocket: cannot resolve SSL_set_psk_client_callback
    qt.network.ssl: QSslSocket: cannot resolve TLSv1_1_client_method
    qt.network.ssl: QSslSocket: cannot resolve TLSv1_2_client_method
    qt.network.ssl: QSslSocket: cannot resolve TLSv1_1_server_method
    qt.network.ssl: QSslSocket: cannot resolve TLSv1_2_server_method
    qt.network.ssl: QSslSocket: cannot resolve SSL_select_next_proto
    qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_next_proto_select_cb
    qt.network.ssl: QSslSocket: cannot resolve SSL_get0_next_proto_negotiated

    But I don't think there is a context to this JSON error.



  • I'm sorry, didn't realize that using deprecated qwebchannel.js ... problem solved.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.