Debugging starts, failed, finished



  • I am using Linux(Ubuntu 10.04) . I configured QT5.5 (qt-opensource-linux-x86-5.5.0.run) . My application can be compiled only in "run "(Cntrl+R) mode . I cannot compile in "debug" mode (F5) .
    If i run my application using F5 i get following in the "Application output " tab.

    Debugging starts
    Debugging has failed
    Debugging has finished
    

    If i run using cntrl+R my application runs .
    I feel debugger is not configured properly.
    I installed newer version of Gdb using these command .

    ./configure --prefix /usr/local/gdb-python2 --with-python
    make
    make install
    

    I then checked version and it says .

    root@userdesktop:/home/user# /usr/local/gdb-python2/bin/gdb --version
    Python Exception <type 'exceptions.ImportError'> No module named gdb: 
    /usr/local/gdb-python2/bin/gdb: warning: 
    Could not load the Python gdb module from `/usr/local/gdb-python2/share/gdb/python'.
    Limited Python support is available from the _gdb module.
    Suggest passing --data-directory=/path/to/gdb/data-directory.
    
    GNU gdb (GDB) 7.9
    Copyright (C) 2015 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "i686-pc-linux-gnu".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    <http://www.gnu.org/software/gdb/bugs/>.
    Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.
    For help, type "help".
    Type "apropos word" to search for commands related to "word".
    

    I then checked python version and it says

    (gdb) python print sys.version
    2.6.5 (r265:79063, Feb 27 2014, 19:56:00) 
    [GCC 4.4.3]
    

    I cannot set breakpoints any where in the code.. My application just runs and gives the output.
    Why cant i set breakpoint?. Is it the issue with python? because python version should be greater than 2.7 .


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.