[solved] Application wants debug-dlls (QtCored4.dll etc) although built with CONFIG+=release



  • I'm trying to deploy a Qt-Application.

    The qmake-line looks like this:
    @qmake.exe D:\MyProject\Project.pro -r -spec win32-g++ "CONFIG+=release"@

    When I put the application on another PC it won't start because it lacks QtCored4.dll and so on.
    All the non-debug .dlls (QtCore4.dll etc.) are present in the application folder.

    What am I doing wrong?



  • Hello,

    First try to post you Project.pro file i think your answer is in.

    Here is bit of documentation for CONFIG

    CONFIG
    Option
    release: The project is to be built in release mode. This is ignored if debug is also specified.
    ...
    Check debug is not specified in your .pro file



  • This is the .pro-file:

    @# Add more folders to ship with the application, here
    folder_01.source = qml/MyProject
    folder_01.target = qml
    DEPLOYMENTFOLDERS = folder_01

    Additional import path used to resolve QML modules in Creator's code model

    QML_IMPORT_PATH = plugins

    Set the icon on Windows

    RC_FILE = icon.rc

    CONFIG += crypto
    CONFIG += kqoauth

    INCLUDEPATH += libs/kqoauth/include libs/kqoauth/src
    LIBS += -Llibs/kqoauth/lib -lkqoauthd0

    SOURCES += main.cpp logbrowserdialog.cpp logbrowser.cpp icecastserver.cpp
    qmlcppmediator.cpp
    twitter.cpp

    HEADERS += logbrowserdialog.hpp logbrowser.hpp
    icecastserver.hpp
    qmlcppmediator.hpp
    twitter.hpp

    QT += core gui network

    TARGET = Project
    TEMPLATE = app

    Please do not modify the following two lines. Required for deployment.

    include(qmlapplicationviewer/qmlapplicationviewer.pri)
    qtcAddDeployment()

    Compile Resources in Binary

    RESOURCES +=
    resources.qrc@



  • Never been on Windows, but.... already tried a full clean build? It sometimes happened to me that the executable just won't get cleaned & rebuilt... quite some time wasted, really :).

    --



  • Yeah I did a clean and the filesize of the application is significantly smaller now (411KB instead of 2,4MB with the debug-build).



  • Do you have any other DLLs which are built with this project?



  • Dude, you know what you are? Pure genius!

    That was the solution.
    One of the non-Qt-libraries I built myself was in debug-mode.

    It works now without requesting the debug-dlls.



  • Thanks...that was just a little hint...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.