Simple Qwidget application crash in debug environment [SOLVED]



  • Hi there,

    I just installed new Qt 5.5 (with mingw compiler) and created the simple QWidgets application. Only the basic window, no changes have been done.

    (New Project -> Application -> Qt-Widgets-Application)

    The application has been compiled, and after trying to debug it following crash occurred:

    http://i.imgur.com/OIRptAC.jpg
    http://i.imgur.com/8iP9hsH.jpg

    1st message as text:
    Problemsignatur:
    Problemereignisname: APPCRASH
    Anwendungsname: Test.exe
    Anwendungsversion: 0.0.0.0
    Anwendungszeitstempel: 00030000
    Fehlermodulname: .5\mingw492_32\bin\Qt5Cored.dll!__cxa_throw_bad_array_new_lengt
    Fehlermodulversion: 6.3.9600.17936
    Fehlermodulzeitstempel: 55a68dd1
    Ausnahmecode: c0000139
    Ausnahmeoffset: 0009d4f2
    Betriebsystemversion: 6.3.9600.2.0.0.256.48
    Gebietsschema-ID: 1031
    Zusatzinformation 1: 1abe
    Zusatzinformation 2: 1abee00edb3fc1158f9ad6f44f0f6be8
    Zusatzinformation 3: 1abe
    Zusatzinformation 4: 1abee00edb3fc1158f9ad6f44f0f6be8

    2nd message as text:
    :-1: Warnung: Eine Ausnahme wurde ausgelöst:
    Exception at 0x76f9d4f2, code: 0xc0000139: DLL entry point not found, flags=0x0.

    When I used the release build Test.exe in the deployment folder with the necessary Dlls it worked. But I guess in debug environment of QtCreator there is no need to copy the Dlls to every application build folder, or is it? The QtCreator 5.3 worked well, 5.4 and 5.5 are not.

    Do you have any ideas what could be wrong? I removed all Mingw and Qt installations, cleaned up the registry before installing 5.5 and used the default installation configuration.

    many thanks in advance.
    Martin



  • This post is deleted!

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.