Qt Creator and Building example widgets on embedded platforme



  • Hello
    Apologizes if this is rather target specific, but I think the question is generic enough to ask hear.
    Qt Creator Texas Instruments OMAP-L138 and Building Texas Instruments DVSDK qtopia example widgets

    I have Qt Creator 2.1.0 based on Qt 4.7.1 (32 bit) running under Ubuntu 10.04.LTS with a target of a Texas Instruments OMAP-L138 evaluation board.
    I went in to Qt Creator Tools-->Options-->Qt4 and manually added a Version named Qt Embedded and pointed the qmake location to be
    /home/user/ti-dvsdk_omapl138-evm_4_02_00_06/linux-devkit/bin/qmake
    Things I note:

    1 there is no mkspec:
    showing up when I hover the mouse over my manually added a Version named Qt Embedded.

    2 there is never a Auto-detected Qt in PATH.

    3 there is a message at the bottom Qt Creator Tools-->Options-->Qt4
    Qt version is not properly installed, please run make install.

    Where does it want me to run make install from ? Or ??

    How do I get a mkspec into the above, and do I need it?

    How do I get the Auto-detected Qt in PATH to show up, or is it necessary?

    If I shut down Qt-Creator and restart from the command line ie
    user@user-desktopUbuntuLTS:~/QtSDK/QtCreator/bin$ ./qtcreator,
    the previously manually added Version named Qt Embedded is no longer there?

    My goal is to be able to compile some of the supplied Qt widgets in the Texas Instruments DVSDK using Qt-Creator and run them on the Texas Instruments OMAP-L138 evaluation board touch screen.

    Any help or point me to links that may be able to help would be appreciated...
    I am a newbie to Qt-Creaitor, and may be trying to do this all wrong?

    Please advise any links / advice / examples you can for my issues... Thanks
    gusQt1



  • Addition:
    I can compile / build / run the sample widget's under the command line tools on the DVSDK.


  • Moderators

    I was cross compiling Qt for an OMAP processor board in April.
    Since I did not have installed QtCreator prior to compilation I was doing the cross compilation externally. There are no OMAP mkspecs available to my knowledge. You need to adapt the settings for your compilation from a close set.



  • Where does the Qt installation come from - did you build it yourself?
    If you run 'qmake -query' - what does it say?

    To make Qt Creator find your Qt installation in the PATH, you should simply add the /home/user/ti-dvsdk_omapl138-evm_4_02_00_06/linux-devkit/bin directory to your PATH, in the shell from which you start Qt Creator, or in your .bashrc or some other file read at startup or when you open a new shell.

    But adding it yourself in Qt Creator should work just as well - getting it from the PATH is just a convenience.



  • Thanks for the fast reply guys...

    ludde

    The Qt installation on
    /home/user/ti-dvsdk_omapl138-evm_4_02_00_06/linux-devkit/
    came from Texas Insterments... It is part of the DVSDK (Digital Video Software Developers Kit)
    I do not know it's origin... other then it is installed when you install the DVSDK. Don't think that helps you to much, sorry.

    If you run ‘qmake -query’ – what does it say?
    user@user-desktopUbuntuLTS:~/ti-dvsdk_omapl138-evm_4_02_00_06/linux-devkit/bin$ ./qmake -query
    QT_INSTALL_PREFIX:/linux-devkit
    QT_INSTALL_DATA:/linux-devkit
    QT_INSTALL_DOCS:/linux-devkit/doc
    QT_INSTALL_HEADERS:/linux-devkit/include
    QT_INSTALL_LIBS:/linux-devkit/lib
    QT_INSTALL_BINS:/linux-devkit/bin
    QT_INSTALL_PLUGINS:/linux-devkit/plugins
    QT_INSTALL_TRANSLATIONS:/linux-devkit/translations
    QT_INSTALL_CONFIGURATION:/etc/xdg
    QT_INSTALL_EXAMPLES:/linux-devkit/examples
    QT_INSTALL_DEMOS:/linux-devkit/demos
    QMAKE_MKSPECS:/linux-devkit/mkspecs
    QMAKE_VERSION:2.01a
    QT_VERSION:4.6.3

    Hope that helps you guys help me the newbe...



  • also ludde as I mentioned I am able to build / compile / run some of the sample widgets in the DVSDK using command line... i.e qmake / make etc. All I have been trying to do, for a wile now i.e. I've been hacking at trying to get Qt Creator to work for some time, is be able to use Qt Creator to design some custom widgets for a pro audio interface I'm working on with the ARM / DSP OMAP-L138... Thanks hope you or the guys hear can help...
    Go easy I'm a newbe...



  • If you can build from the command line, and Qt Creator does not think your Qt installation is OK, I'm afraid it's really difficult for me to understand why, sorry. I've never had any similar problem - pointing Qt Creator to the qmake program has always worked for me.



  • I’m afraid it’s really difficult for me to understand why, sorry. I’ve never had any similar problem – pointing Qt Creator to the qmake program has always worked for me.

    "difficult for me to understand why"...

    ludde / all...
    Yep, kind of figured that... Anywhere, "anyone out there" (other forum's, web / sites / documentation / people to talk to / etc. etc.), you can suggest to go to solve it, or, any further advice, at all, would be appreciated...
    I have posed the question on the TI e2e forum, as well as qtcentre.org.
    I have also seen this thread
    http://developer.qt.nokia.com/forums/viewthread/2641/
    which somewhat relates... but I'm not sure I understand what Zaoolin did to make it work...

    Thanks
    gusQt1



  • Ludde Would you suggest I build / reinstall ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.