Qwebkit links with .org do not work - SOLVED



  • Hi All,

    I have a strange issue. I use Qwebkit and subclassed QWebPage. Any links such as .co.uk work fine but .org do not. They work on the development machine Windows 8 and Windows 7 if the QT environment is on that machine. I use the deployment method of:

    set PATH=C:\Qt\5.4\mingw491_32\bin;%PATH%

    then

    C:\Qt\5.4\mingw491_32\bin\windeployqt.exe --webkit2 --dir C:\pathToApp C:\pathToApp\applicationName.exe

    Note that if I set a link to someDomainNameHere.co.uk it will work if I set a link to someDomainNameHere.org it will not work Likewise with .gov.uk as well I see to remember

    Totally confused! How do I start to debug that? The same application and links works on a Mac without the QT environment.

    Thx in advance.



  • Using Burpsuite as a proxy I can see that clicking on the .org domain link on a machine that does not work shows that no effect happens but a .co.uk domain does show the requests.

    Very strange!



  • Definitely related to ssl but not sure why it works on some machines and not others. I need to set the ignore ssl errors or something like that. Will post back later if I have the answer. Where is the ignore ssl errors set?



  • Solved from https://forum.qt.io/topic/17139/solved-how-to-use-ssl-support-without-manualy-building-qt-libraries/6

    added CONFIG += openssl-linked
    copied from the QtSdk the (MingW) libeay32.dll and ssleay32.dll in the same folder as the executable