Do I have to pay to update Qt tools since now? [Solved]



  • Hi, I tried to check the updates from the Maintenance Tool and when I try to login it shows the next message.

    No valid license available in your Qt Account for this host platform.
    
    Please renew your license(s) from Qt Account.
    

    I filled the form that appears after clicking on the link, but I don't get anything.


  • Qt Champions 2016

    mine says the same after i updated the Maintenance tool. must be some kind of bug.



  • It seems you're right. Qt replied me in a post in Google+.

    I hope it's repaired soon (if it's really a bug), because that bug left me really disappointed.


  • Qt Champions 2016

    @Cold_Distance
    well
    reading about v-play at
    http://planet.qt.io/
    let me to think that you can just download v-play yourself
    from
    https://v-play.net/download/
    first line says
    "Note: If you already installed Qt 5 on your system, you can skip this step and follow the instructions here."
    but seems to want me to make a profile when clicking "here" so do not know what you will get in there.

    Thanks for updating this q.



  • In Add V-Play to your existing Qt installation section of this webpage I saw a possibility to install V-Play.

    I don't know if I can do it with the current Maintenance Tool, although the impossibility to update the Qt official tools is something that worries me too.

    Well, I will continue as I can programming with Qt.



  • Well, I saw that I can run the Maintenance Tool has super user trough the console.

    I will become the owner of full Qt stack.


  • Qt Champions 2016

    so if you run it as root, it works ?



  • I had this issue with the maintenance tool (the message about no valid license). I used to have an account on the Qt website but I didn't log in for a while.

    I tried to log in to the site. https://account.qt.io/ and I think I created an account with my existing e-mail address. I think that after that, running the maintenance tool worked for me as expected.


  • Qt Champions 2016

    @frankiefrank
    Thanks for your. i tried logging in but still wont let use the tool.



  • @mrjj

    Yes, doing "sudo" directly on the executable of Maintenance Tool (I use Kubuntu/Ubuntu) it worked perfect.

    Now I removed Qt Open Source and I installed V-Play, that installs the full Qt stack, and I put it in a subfolder in my own home folder to not have issues with permissions.

    I recommend not install Qt in /opt, but in home folder.


  • Qt Champions 2016

    ok so you solved it :)

    I ended up upgrading to 5.5 and the M. tool start working again.



  • I'm now facing this same problem with the latest Maintenance Tool (updated April 6th, 2017). What should I do?

    All I can get is the message:
    No valid license available in your Qt Account for this host platform.
    Please renew your license(s) from Qt Account.


  • Qt Champions 2016

    @vlada
    And there is not a skip button ?
    or a way to ignore it ?
    Note if there is a skip button but its grey,
    remove any text form email etc edit fields.



  • Thanks, I didn't notice that I can skip it. I was always using my Qt account.


  • Qt Champions 2016

    @vlada
    well if u have a commercial licence that the right thing to do but if you are using open version then
    skipping should be just fine :)


Log in to reply