Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] Change build path/directory



  • Hello,
    this seems like it is easealy done, but I just can't get it to work.
    I want to open and build my project on an other computer with the same Qt Version (for deployment tests).
    For test cases I made a simple demo project to test if I installed the qwt plugin correctly.
    Now when I want to build my real project, the debug build gets build in the same directory as the demo and when I want to build a release version the directory path is the same as the path on the other computer.
    New PC: C:\users\user1\build\release thats where I want to build the release
    Old PC: C:\users\user1\build-MyProject-release thats what Qt says where it wants to build the release
    So the compiler stops and gives me the error: Can't create directory: "C:\users\user1\build-MyProject-release" on the new PC.
    I also tried to change the build path on the old PC with the given options, but the build directory stays the same.

    I have set the build path in "Tools>Options>Build&Run" but the changes there are doing nothing.
    I also tried to set the DESTDIR variable in the .pro file. I used this: link text for the .pro file.

    Both projects are the same from a Server with SVN. So I kinda understand why the release build path is set to the path of the old computer but I don't understand why Qt doesn't accept my path changes.

    I use:
    Qt Creator 3.3.1
    Qt 5.4.1

    So my question now is: Why does Qt doesn't change the build directory name/path and how could I change it.

    Thanks for any help



  • @Tecnova
    Did you run qmake from Qt creator after changing build folder?


  • Lifetime Qt Champion

    and if you just change it via Projects (lefts side, under welcome, edit etc) and then
    the Build directory in the General part ?

    The "Tools>Options>Build&Run is the default directory and will take effect if you make a new project.

    As far as i Know.



  • ok that was the problem. In the Projects was the wrong build path. Now it works
    thanks a lot


Log in to reply