[Solved] QtCreator 2.2 missing quotation mark completion?



  • Hi all,

    I'm working in the new QtCreator now, which has perfectly updated the highlighting from custom classnames!

    I only miss the completion from quotation marks. In the last (2.1) when you pushed the quotation mark key, not 1 but 2 marks came in.
    Now you have to "space" the quotation marks and do it 2 times instead of one.

    I also noticed that if you include a custom header file after "spacing" the quotation mark the possible header dont popup.
    In the old situation you could select from a popup menu which header to include as it still does with the standard headers tagged with "<" and ">" .

    My question is,
    Is there an configuration option i have to switch on, which i can not find. Or do i have to file a bug/request?


  • Moderators

    I still get "" when pressing the '"' key.

    We try to be a bit more intelligent when it comes to handling quotation marks if I remember correctly though. You can now e.g. highlight some text and hit '"' to get quotation marks around the highlighted text instead of replacing the selected text. Maybe that extra intelligence is biting you?



  • That's a nice feature. I didn't realise that. I'll have to remember that as I always forget quotation marks when copy/pasting. ;-)

    I did notice the extra logic when doing Ctrl+Left/Right to skip words. It now skips to next camelcased word in variable names. Also nice ;-)



  • Hi Tobias Hunger,

    Thanks for your reply!

    I suspect that i have not putting the options right.
    I also not get that nice feature you described, so im thinking that im doing something wrong.
    But what?



  • Solved the problem.
    I had put my settings wrong from the keyboard layout, so it had nothing to do with Qt.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.