[closed] sdk 1.1 bombs on perl



  • installed 1.5gb package , it bombs when perl trying to compile qmake, source code is there but no exe.



  • If there's an error, why don't you share it? Are you installing "this version of Qt SDK":http://labs.qt.nokia.com/2011/05/04/qt-sdk-1-1-released/ ?



  • yes, that version. there was no number with the error, i told it to ignore it and it kept coming up until it got past the qmake module/dependencies.

    that installer also left a lot of junk on the root dir which i deleted. i don't see a log file of any kind.

    i got the mediaplayer demo to compile with mingw

    Running build steps for project qmediaplayer.

    Configuration unchanged, skipping qmake step.

    Starting: "C:\apps\sdk\NokiaQT\mingw\bin\mingw32-make.exe" -w

    "C:\apps\sdk\NokiaQT\mingw\bin\mingw32-make.exe" exited normally.

    no qmake was built with the install



  • 1st error
    bash.exe: warning: could not find /tmp, please create!

    2
    "runInstall(ExitCode: 2) went wrong
    'C:\apps\sdk\NokiaQT/Maemo/4.6.2/bin/env.exe -i /bin/sh --login C:\apps\sdk\NokiaQT/Maemo/4.6.2/postinstall/postinstall.sh --nosleepontrap'"



  • C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian1Qt473>echo patching .qmake.cache
    patching .qmake.cache

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian1Qt473>rename .qmake.cache .qmake.cache.PREV

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian1Qt473>copy TEMPLATE.qmake.cache .qmake.cache
    1 file(s) copied.

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian1Qt473>set PATH=C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian1Qt473....\tools\perl\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;c:\bin;C:\apps\sys\quicktime\QTSystem;C:\apps\pub\swftools;;C:\apps\eng\matlab\runtime\win64;C:\apps\eng\matlab\bin;c:\php;C:\Perl\bin;C:\Perl\site\bin;c:\php\ext;C:\python26;C:\python26\Scripts;C:\apps\pub\komodo;C:\apps\Java\jrockit-jdk1.6.0_22\jre;C:\apps\Java\jrockit-jdk1.6.0_24\jre\bin;C:\apps\Java\jrockit-jdk1.6.0_24\bin;C:\apps\sdk\ruby192\bin;C:\Users\alexander\AppData\Roaming\Python\Scripts;C:\apps\video\ffmpeg\shared-x64\bin;C:\apps\net\openssl;C:\apps\sdk\google_app;c:\docs\perl

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian1Qt473>perl -i.bak -p -e "use Cwd;$p=getcwd();s/$(EPOCROOT)/$p//ig" .qmake.cache

    then is pops up a windows that says perl.exe has stopped working close or debug



  • exit code -1073741819

    error during install
    com.nokia.ndk.tools.symbian.symbian1.473



  • next bombing of perl

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian3Qt473>echo patching .qmake.cache
    patching .qmake.cache

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian3Qt473>set CWD=C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian3Qt473

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian3Qt473>rename .qmake.cache .qmake.cache.PREV

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian3Qt473>copy TEMPLATE.qmake.cache .qmake.cache
    1 file(s) copied.

    C:\apps\sdk\NokiaQT\Symbian\SDKs\Symbian3Qt473>perl -i.bak -p -e "use Cwd;$p=getcwd();s/$(EPOCROOT)/$p//ig" .qmake.cache

    exit code
    -1073741819

    symbian3.473



  • sdk installs ok on my osx partition


  • Moderators

    So where does it not install when it installs fine on mac osx? I guess windows, but which version? Are you using the perl shipped with the SDK or another version you had installed already? Some more information would help.

    Did you file a bug report? Complaining here will most likely not get you any developer attention.



  • i wasn't complaining about anything, so piss off.

    do you understand english?

    my original post was just a statement
    "nstalled 1.5gb package , it bombs when perl trying to compile qmake, source code is there but no exe."

    this person wanted details "secretninja"
    "If there’s an error, why don’t you share it? Are you installing this version of Qt SDK [labs.qt.nokia.com] ?"

    so i posted it for him.

    i posted this as a courtesy to others but will not do so in the future so find the errors yourself.

    I have already hacked a solution, no I will not post it.



  • Here people are helping each other ... you wanted help and both of us ( Tobias and I ) just wanted more info in order to help you. It's a discussion board after all!

    If you don't want to post your solution - don't ... but do you think that will help you in the future (here or on another forum).

    Have a nice day :)


  • Moderators

    Closing this thread before it turns into a name-calling session.

    I do apologize for the word "complaining" which seems to have triggered this.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.