[Moved] Qt SDK 1.1 incompatible with Mac OS X 10.5?



  • Hello,

    I've tried to install the Qt SDK 1.1 on my mac mini which is running Mac OS X 10.5.8 and it always results in a program crash :( Google and the forums search here didn't help me to find out if this is just on my machine. The Qt Creator 2.2 binary runs without any errors. The old Qt SDK (with 4.7.0) also had no problems.

    Program outputs:
    @dyld: lazy symbol binding failed: Symbol not found: __ZSt16__ostream_insertIcSt11char_traitsIcEERSt13basic_ostreamIT_T0_ES6_PKS3_l
    Referenced from: /Volumes/Qt SDK Installer/Qt SDK Installer.app/Contents/MacOS/./Qt SDK Installer
    Expected in: /usr/lib/libstdc++.6.dylib

    dyld: Symbol not found: __ZSt16__ostream_insertIcSt11char_traitsIcEERSt13basic_ostreamIT_T0_ES6_PKS3_l
    Referenced from: /Volumes/Qt SDK Installer/Qt SDK Installer.app/Contents/MacOS/./Qt SDK Installer
    Expected in: /usr/lib/libstdc++.6.dylib
    @



  • Moved this to the Installation and Deployment forum.

    Please feel free to open an issue at the "bug tracker":http://bugreports.qt.nokia.com, instructions are on the wiki article "Reporting bugs in Qt ":http://developer.qt.nokia.com/wiki/ReportingBugsInQt; you might get a quicker answer from the SDK devs then.



  • I just wanted to make sure to not enter bugs which are already known :)

    Bug report is here: http://bugreports.qt.nokia.com/browse/QTSDK-704



  • Found a bugreport with the answer: http://bugreports.qt.nokia.com/browse/QTBUG-13943?focusedCommentId=134068&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-134068

    [quote]I'm afraid I don't think we can fix this issue. The pre-built binary packages for Qt 4.6 and Qt 4.7 are built on 10.6, because when built on 10.5 they fail to install on 10.6. As packages built on 10.5 install fine on 10.5, we believe that Apple have created some kind of compatibility break between the 10.5 and 10.6 installation infrastructure.

    Unfortunately we are unable to devote sufficient resources to producing and testing a second set of packages specifically for 10.5. Instead, we would encourage users to either upgrade to 10.6 (the upgrade is cheap and has many worthwhile improvements over 10.5), or to build Qt from source on 10.5.[/quote]



  • Ah, what a pity :-/

    Although it's strange, as regular Qt apps compiled on 10.6 run fine on 10.5.



  • Yeah, that sucks. I don't want to spend any money on a system I don't like... Just wanted to run OSX because the crappy GMA 950 has no GLSL support on Windows but on OSX.

    As he wrote, normal programs seem to work but it might be something in the apple installation framewor.



  • It's not that bad, actually. On a OS X box, it is quite easy to install the components manually:

    • Get Qt Creator 2.2 from the "Qt Creator Download Page":http://developer.qt.nokia.com/wiki/QtCreator2.2Download, (it's just an DMG with an application, no installer)
    • Get Qt 4.7.3 sources from "Qt download pages":http://qt.nokia.com/downloads, choose LGPL, the column "Qt: Framework Only" on the right has an introductory paragraph, at its end there are download-links for the sources (tar.gz and zip)
    • extract the sources somewhere
    • call configure, the standard prefix is /usr/local/Trolltech/Qt-4.7.3, I just leave it as is. You might want to add some more config options (switching carbon/cocoa, the desired SDK, the cpus you want in the universal binaries, etc)
    • call make -j8 (if you have a double quad core)
    • call sudo make install
    • make the installed Qt visible to Creator: call the preference (Cmd-,), choose Qt4 on the left and add the newly installed Qt version (path to qmake is /usr/local/Trolltech/Qt-4.7.3/bin/qmake), expand the details and let Creator compile the debugging helper

    If you want to use the command line tools in a shell, then add /usr/local/Trolltech/Qt-4.7.3/bin to your path. I personally have a symlink in /usr/local/Trolltech/Qt (without version) pointing to the current version, this way I do not have to change the path every time a new Qt version is out :-)

    Feel free to come back and ask, if you have further questions.



  • Thanks for the instructions, I've already built Qt several times (takes about 2 hours on this machine). Actually there's no need to compile it myself, the normal "Qt Libs" package works well except of lupdate and lrelease - which have the same dyld error.
    The sad thing is, I wanted to use the SDK to also test on my phone via MADDE. And the last standalone version I can find is from October 2010. A while ago I've seen there's a way to build MADDE my own but I think that is not worth the efforts.

    I just can't see why the SDK installer fails but the normal libs installer works.



  • That's really strange, yes. But one would need access to the installer itself to debug this.


  • Moderators

    Volker: The installer framework is available on gitorious under qt-labs/installer-framework.

    So feel free to get your debugger out:-)

    Sorry, I can not link to that page since that triggers my post to be considered spam:-(



  • For the records: https://qt.gitorious.org/qt-labs/installer-framework

    I had a quick look and suspect it to be an issue with the SDK against the installer is built (located in /Developer/SDKs).

    But while it may be possible to create an installer binary that runs on 10.5, it would not help much, as it would install Qt libs which do not run on 10.5 reliably (namely the lrelease and lupdate binaries). This would create more trouble once the installer did run an put everything in place.

    So, to proceed on the SDK installer, one would need 10.5 enabled framework libraries and binaries in the first place.

    I'm not quite sure, if to proceed, and if yes how...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.