[SOLVED] How to fix QtCreator and add QtSerialPort?



  • I've been trying to add the SerialPort-library to my pre-installed Qt-packages (Ubuntu 14.04). It failed: QtCreator threw an error on "QT += serialport" and "#include <QSerialPort>" lacked highlighting.

    Next, I decided to try an installation from scratch. Being an amateur, I deleted the folders /usr/include/qt4 and /usr/include/qt5. Subsequently, I've used the apt-get functionalities to delete and install packages.

    At this stage I've got my two deleted directories back (or: I installed 'qt-sdk' and some other packages), but things don't work as they used to do. When I open QtCreator, I'm getting the following error message:

    "file:///usr/share/qtcreator/welcomescreen/welcomescreen.qml:30:1: module "QtQuick" is not installed
    import QtQuick 2.1
    ^ "
    ,
    although there is a QtQuick-folder in /usr/include/qt5. QtCreator opens next but the screen freezes. After opening a project, I'm able to go through its code but when I try to build it, I don't receive any response.

    In the meantime I've found a broken 'plugins' link in /usr/share/qt4 that used to refer to /usr/lib/qt4/plugins. I've replaced this symbolic link with one that refers to the existing /usr/lib/x86_64-linux-gnu/qt4/plugins hoping that this would magically solve my problem. It didn't.

    Any suggestions on how I would be able to a) get QtCreator back up and running, b) add the QtSerialPort-library?



  • add the QtSerialPort-library?

    Just install the qtserialport library from the Ubuntu's repo. Or try to read the WIKI in case you want to have a fresh version of QSerialPort.



  • In the meantime, I've fixed a). The package 'qtcreator' depends on:

    qtdeclarative5-qtquick2-plugin
    qtdeclarative5-controls-plugin
    qtdeclarative5-window-plugin
    qtdeclarative5-localstorage-plugin,

    which aren't automatically installed while installing 'qtcreator. Check also https://bugs.launchpad.net/ubuntu/+source/qtcreator/+bug/1339628.

    Thanks for the response, Kuzulis. Now i'll try (again) to tackle b).



  • Ok, following the wiki worked.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.