[SOLVED] Qt debugger doesn't seem to work anymore



  • I'm hoping somebody call help me troubleshoot.
    I'm using Qt Creator 3.1.2 / Qt 5.3.1 on Windows 8.1 (64bit) and MSVC2012 for the compiler.

    I'll set a breakpoint in code, and run in debug mode. The breakpoint triggers and I get into the code and can see the call stack. But then any attempt to step into it, and nothing happens.. Now and again if I wait 30-45 seconds, it'll actually start stepping through, but often when that does work I can't seem to watch the value of any variables.. More often than not, it just sits there until I force-quit (by choosing Debug->Abort Debugging). This situation has rendered the debugger completely useless.

    I have to believe it's supposed to work and be pretty quick too.

    What might I look at first to try to troubleshoot? I have already tried full clean/rebuild and reboot. The problem persists.

    Thanks!



  • So while I didn't figure out why, I did resolve the problem by restoring my development VM to a snapshot I made right after initially installing Qt.. Now things work again as expected.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.