[SOLVED]Cannot compile Qt 5.4.1



  • I downloaded the source files for Qt 5.4.1 and attempted to compile. It originally failed because I didn't have the DirectX SDK installed. It complained about ANGLE. I installed the SDK, cleaned the Qt build, re-ran configure and nmake. This time, configure did no complain about missing ANGLE, but ultimately the build still failed with the following error:

    fatal error C1083: Cannot open include file: 'GLES2/gl2.h': No such file or directory

    I am trying to compile it on Windows 7 via Visual Studio 2010

    Any help would be appreciated



  • I found this:
    https://forum.qt.io/topic/35741/qt-5-2-vs2010-gles2-gl2-h-no-such-file-or-directory/6

    Adding $(QTDIR)\include\QtANGLE to Project Properties->C++->General->Additional Include Directories has solved the problem for me.



  • I'm following the instructions that came with the downloaded source bundle, which states:

    Windows:
       --------
    
         Open a Windows SDK (7.0, 7.1 or later) command prompt. Ensure that the
         following tools can be found in the path:
         * Perl version 5.12 or later   [http://www.activestate.com/activeperl/]
         * Python version 2.7 or later  [http://www.activestate.com/activepython/]
         * Ruby version 1.9.3 or later  [http://rubyinstaller.org/]
    
         cd <path>\qt-everywhere-opensource-src-<version>
         configure -prefix %CD%\qtbase -opensource -nomake tests
         nmake // jom // mingw32-make
    
         To accelerate the bootstrap of qmake with MSVC, it may be useful to pass
         "-make-tool jom" on the configure command line. If you do not use jom,
         adding "/MP" to the CL environment variable is a good idea.
    

    There's no method to provide such paths, as I am not compiling it in the IDE

    The full error is thus:

    c:\_views\roscoe\qt-everywhere-opensource-src-5.4.1\qtbase\include\qtgui\../../s
    rc/gui/opengl/qopengl.h(99) : fatal error C1083: Cannot open include file: 'GLES
    2/gl2.h': No such file or directory
    


  • The problem here was with my environment. Initially I did not have the Direct X SDK installed. After installing it, re-running configure.bat and nmake did not fix the problem. I completely cleaned out the build, rebooted my computer and tried to recompile again. This time, it failed but due to a problem finding Python. I fixed this and the build worked.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.