Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt SDK 5.x Linux Installation: Broken Dependencies



  • I downloaded the complete Qt SDK 5.x for Linux from this link:

    Qt SDK Download

    The native installer completed but complained about the following broken dependencies on Ubuntu 12.04:

    • CMakeProjectManager

    • Qnx

    • RemoteLinux

    • Valgrind

    I am quite new to Qt development, but it seems that the SDK should not have any broken dependencies. I am experienced enough with Linux to know that trying to fix broken dependencies can be a snipe hunt, so I am hoping someone can offer some advice about how to proceed.

    Also, under Tools-->Options-->Qt Versions, there is a warning icon beside the entry for the qmake binary and the problem seems to be there is no qmlviewer installed.

    Any advice is appreciated.


Log in to reply