[SOLVED]issue building qt statically on windows

  • So I'm trying to build qt statically on windows, I keep getting the same four errors.
    configure -platform win32-msvc2013 -static -opensource

    1. Couldn't find qmake.pdb

    2. couldn't find qmake.ilk

    3. couldn't find qmake.tds

    4. can not open file libcmp.lib

    I've read the documentation, I've followed the necessary steps, can't figure out what I'm missing here.

    EDIT: Okay so after Trying both microsoft visual express 2013 and 2012 my problem was still there. It seems there was an issue with the compilers, now I tried uninstalling them re-installing them, extending paths, running the vcvars etc.. Nothing worked.

    So I grabbed a copy of microsoft visual express 2010 and what you know my problem went a way the configuration was successful and the build is going smoothly :)

  • Did you start configure from Visual Studio command promt?

    You need Visual Studio compiler environment set properly.

  • yes I've tried with the msvc 2013 dev promt, i've also run the vcvars