QT SDK installation problem



  • I'm trying to install QT SDK 1.1 Release Candidate from http://developer.qt.nokia.com/prereleases on Window 7

    It's stuck on "installing component USB Network Drive" phase and stays here forever (waited fro 12 hours).
    No errors are logged in event viewer. I've tried both online and offline installation. Any ideas about possible causes?



  • I've had almost the same problem like you - "here is my solution":http://developer.qt.nokia.com/forums/viewthread/5092/ to the problem (and the problem itself).

    Are you using Windows? (My guess is "yes".)



  • I tried to install as an Administrator and in safe mode: It's giving error and pops up with "retry".

    But I was able to go further with normal (not safe mode) after several restarts. But now I get follow messages unlimited times repeated:

    @D:\ProgramFiles\QtSDK\Maemo
    bash.exe: warning: could not find /tmp, please create!

    Creating default target fremantle-pr13 ...
    This may take a while ...

    Working on sysroot fremantle-arm-sysroot-20.2010.36-2-slim

    .
    .
    .
    .
    .
    9
    .
    ..
    .

    ...

    ..
    .

    .
    ..
    5
    .
    .
    .
    .
    4
    .
    "runInstall(ExitCode: 9) went wrong
    'D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/env.exe -i /bin/sh --login D:\ProgramFiles\QtSDK/Maemo/4.6.2/postinstall/postinstall.sh --nosleepontrap'"

    "D:\ProgramFiles\QtSDK/Maemo/rebase/msysgit_rebase.exe -b 0x5200000 -o 0x10000 -v D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-crypt-0.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-minires.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-gdbm-3.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-bz2-1.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-z.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-ssl-0.9.8.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-perl5_6.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-crypto-0.9.8.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-1.0.dll "

    bash.exe: warning: could not find /tmp, please create!

    Creating default target fremantle-pr13 ...
    This may take a while ...
    "runInstall(ExitCode: 1) went wrong
    'D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/env.exe -i /bin/sh --login D:\ProgramFiles\QtSDK/Maemo/4.6.2/postinstall/postinstall.sh --nosleepontrap'"
    "D:\ProgramFiles\QtSDK/Maemo/rebase/msysgit_rebase.exe -b 0x30000000 -o 0x10000 -v D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-crypt-0.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-minires.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-gdbm-3.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-bz2-1.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-z.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-ssl-0.9.8.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-perl5_6.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-crypto-0.9.8.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-1.0.dll "

    bash.exe: warning: could not find /tmp, please create!

    Creating default target fremantle-pr13 ...
    This may take a while ...

    Working on sysroot fremantle-arm-sysroot-20.2010.36-2-slim
    .
    .
    .
    .
    .
    9
    .
    .
    .
    .8
    .
    .
    ..
    7
    .
    .
    .
    .

    ..
    .
    5
    .
    .
    .
    .
    4
    .
    "runInstall(ExitCode: 9) went wrong
    'D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/env.exe -i /bin/sh --login D:\ProgramFiles\QtSDK/Maemo/4.6.2/postinstall/postinstall.sh --nosleepontrap'"
    "D:\ProgramFiles\QtSDK/Maemo/rebase/msysgit_rebase.exe -b 0x35000000 -o 0x10000 -v D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-crypt-0.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-minires.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-gdbm-3.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-bz2-1.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-z.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-ssl-0.9.8.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-perl5_6.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-crypto-0.9.8.dll D:\ProgramFiles\QtSDK/Maemo/4.6.2/bin/msys-1.0.dll "

    bash.exe: warning: could not find /tmp, please create!

    Creating default target fremantle-pr13 ...
    This may take a while ...

    Working on sysroot fremantle-arm-sysroot-20.2010.36-2-slim
    .
    .
    .
    .
    .
    9
    .
    .
    .
    .8
    ..
    ..
    7
    .
    .
    .
    .
    6
    ..
    .
    .
    5
    .
    .
    .
    .
    4
    .@

    I tried to install both on default directory and on D drive.



  • Sorry to hear that it didn't help. I was fighting with the installer for couple of days and I've almost given up ... but now I'm happy that it all ended well. Wish you luck :)



  • Same problem here. No solution yet.



  • I hope soon the installer would be more stable. Now I'm scared even to think about new installation.



  • Nevermind, Administrator mode worked!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.