Important: Please read the Qt Code of Conduct -

[SOLVED] Serial Port Bug?: Double display of input in Terminal Example | SOLVED

  • I am a beginner of QSerialPort, and learning the Terminal Example, try to communicate with an optical sensor.

    I use that example to talk to the sensor, try to send string to it, however, whenever I type any one letter into the console, it shows up two letter, what's happening?

    It works like below:

    (1) Send command string
    (2) Send ASCII characters
    (3) Continuous receive
    (4) Return to main menu


    Enter hex string of 256 values or less. Press return when finished.
    RR = Receive, CH = Chip Select High, CL = Chip Select Low, DY = 10ms Delay
    R1 = 0x00
    String sent!

    Actually I just typed in "1" and "RR", it shows like I typed in as "11" and "RRRR".

    Has anyone encountered this problem?
    How should I fix this?
    Thank you!

  • If you are using the terminal example provided by Qt then under settings there is "Local echo". Uncheck that.

    Settings is under the gear icon.

  • Thank you! Exactly answered my question

  • You are welcome.

    Please edit your post and set the subject line to include SOLVED

  • @SysTech
    Thank you for you reminding!