ERROR:resource_bundle.cc(639)] Failed to load qtwebengine_resources.pak



  • Hi All,

    I'm working on getting Qt 5.4.1 with qtwebegnine running on an embedded platform. I'm seeing a problem in that when I run ./quicknanobrowser I get some debug messages like the ones below:

    [0327/191707:ERROR:resource_bundle.cc(639)] Failed to load /home/user/qt/sysroot_dev/sysroot/usr/QT/qtwebengine_resources.pak
    [0327/191707:WARNING:resource_bundle.cc(286)] locale_file_path.empty()

    The issue seems to be that qtwebengine is looking for the resources in the directory into which it was installed after being built, “/home/user/hg/qt/sysroot_dev/sysroot/usr/QT/”, and not the actual directory into which it is deployed on the embedded platform which is "/usr/QT". The "qtwebengine_resources.pak" file does exist and is in the "/usr/QT" directory on the embedded platform.

    Is there a way I can tell qtwebengine where to look for the “qtwebengine_resources.pak” file as well as other files? I’ve tried setting up a qt.conf file, but it looks like qtwebengine just ignores it. It feels like there should be an environment variable or some way to tell which directories qtwebengine should check for these files.

    Any help would be appreciated.



  • Hi,

    not sure if you still have this issue, but I wanted to post a solution if someone is looking for it.

    I had the same issue with the deployment on Ubuntu. After looking and manually changing the paths in libQt5Core.so I finally found two solutions:

    1. Manually change the prefix and data path in libQt5Core.so (for example with wxHexEditor) to a relative path instead of the Qt-Installation path.

    2. Just write a qt.conf file:

    [Paths]
    Prefix=<path_to_qtwebengine_resources.pak_folder>
    

    and place this file in the same folder where QtWebengineProcess is located.

    It seems that QtWebengineProcess ignores the qt.conf of the main application and uses it's own hardcoded installation path.
    Maybe it helps someone.



  • Hello.

    I just did a Test Deploy on a Windows 10 and a Windows 7 Clean VM Machine. Qt Version is 5.5.0

    I know this is about Embedded Linux and around 5 Months old.
    But I have the same Problem. It is exactly the same Error Message. Does anybody found a real working Solution yet? The .pak File is in my Application Main Folder. I created a qt.conf and tried the following Settings:

    [Paths]
    Prefix=<QCoreApplication::applicationDirPath()>
    Prefix=<>
    Prefix=<\>
    Prefix=<&PWD>
    

    Nothing worked so far. I could not find the answer, how to tell Prefix to use the current Directory.
    In addition: Has anybody created a BR yet? If not, I can do this.

    Thanks
    Oliver

    EDIT01: Finally I found a way to make it work:

    [Paths]
    Prefix=.
    

    Time will tell if this will bring up other Bugs, Glitches etc.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.