Cannot Connect to QML Emluation Layer (QML Puppet)



  • Hi,
    I just made the fresh QT installation and when I create empty QT Quick project or open any of existing QT Quick examples, my QML designer doesn't work. It shows "Cannot Connect to QML Emluation Layer (QML Puppet)" error.

    I tried to reinstall QT, reboot, installed additional QT kit versions and tried to switch between 32bit/64bit default/opengl versions of the kit and nothing seems to work for me. I was able to successfully run the designer ONCE, and after I closed it and tried to re-open the file it stopped working again. I also tried to search, but didn't find any solution.

    My system is Windows 7, with Visual Studio 2013 installed.



  • Is there any update on this?

    I'm running into the exact same issue. Installed QT 5.5, was able to switch to Design once and now it shows the same error "Cannot Connect to QML Emluation Layer (QML Puppet)". Reinstall didn't help anything. Tried to uncheck "Tools > Options > QtQuick > Qt Qucik Designer > Always use the QML emulation layer provided by Qt Creator" but in the end it showed the same error.

    Windows 7
    Qt version: Qt 5.5.0 MSVC2013 64bit
    Compiler: Microsoft Visual C++ Compiler 12.0 (x86_amd64)



  • I'm having the same issue as above.

    I'm trying to get to grips with QML, but have failed at the first hurdle.

    I've looked around about this issue and found a number of people with the same problem; there doesn't seem to be a real solution. Either a new build happens to fix the problem or there isn't an answer.

    Does anyone have any ideas?

    I've tried:

    • playing around with build kits
    • changing "Options > Qt Quick > Qt Quick Designer > Emulation Layer" option.
    • uninstalling/reinstalling Qt

    Windows 7
    QT 5.5.0 MSVC2010 32bit


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.