Qmake and Make in wrong directories?



  • I'm on OSX
    When I do "qmake -v", I get:
    QMake version 2.01a
    Using Qt version 4.7.4 in /opt/anaconda1anaconda2anaconda3/lib

    This directory doesn't even exist it seems...and I'm using QT 5.4.1
    When I do "which qmake", I get:
    /Users/***/anaconda/bin/qmake

    This DOES exist, but it's not the qmake that comes in the QT installed folder.

    So I have a folder with my project in it and I do run qmake on QT Creator, I get a make file in the folder, so I tried "make" in terminal and I get:

    /usr/lib/x86_64-linux-gnu/qt5/bin/qmake -o Makefile v2.pro
    make: /usr/lib/x86_64-linux-gnu/qt5/bin/qmake: No such file or directory
    make: *** [Makefile] Error 1

    This directory indeed doesn't exist...



  • where is Qt 5.4.1 installed on OSX ? qmake exist in the bin directory where Qt is installed. You need to run the qmake with that path.



  • @dheerendra
    The qmake that is included in the installed QT folder is:

    /Users/***/Qt5.4.1/5.4/clang_64/bin/qmake



  • Ok. you should use /Users/***/Qt5.4.1/5.4/clang_64/bin/qmake sample.pro file to generate make files.



  • @dheerendra ok it seems to have worked, but when I do "make", I still get the error for make


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.