Unable to make deb file of Qt 5.4 app in Ubuntu 14.04



  • I am able to make deb file of Qt 5.2.1 app in Ubuntu 14.04 but unable to make deb file of Qt 5.4 app in Ubuntu 14.04 and got below errors.

    //usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5: undefined reference to `QPdfEnginePrivate::paperRect() const'

    //usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5: undefined reference to `QPdfEnginePrivate::pageRect() const'

    //usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5: undefined reference to `QFontEngine::glyphCache(void const*, QFontEngineGlyphCache::Type, QTransform const&) const'

    I am just guessing that .so files present at the path usr/lib/x86_64-linux-gnu/ are compatible with Qt 5.2.1 but not with Qt5.4.

    There is no change in .so files at the path path usr/lib/x86_64-linux-gnu/ if we install or uninstall Qt 5.2.1 or Qt 5.4.

    If anyone has idea, then please let me know so that I can resolve my issue.

    Thanks.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.