Building qtcreator 3.3.0, Project ERROR: Unknown module(s) in QT: designercomponents-private



  • I'm trying to compile qtcreator 3.3.0 on an armhf (Omap5432-UEVM, debian jessie) system with qt5.3.2 & gcc 4.9.1 installed. While running the initial qmake -r I've run into a number of errors with unknown modules (script, help, quick, x11extras) and I was able to find the apt packages to download, but for this last error: "Project ERROR: Unknown module(s) in QT: designercomponents-private" I can't find the package that contains it.
    I've searched the debian package repositories and QDesignerCompenents is listed but nothing with -private on it.
    I found a source file on gitorius that seems to imply that designercomponents either used to be or is now the name.
    So does anybody know how to get past this problem, what to install to get past this?



  • The problem is due to the install of Qt after build not including some portions of the tree. I had to go into each of the subdirs of qttools/src/designer/src and run make install manually. The qmake of qtcreator then completed.



  • I'm trying to get qtcreator 3.4.0 installed and it's throwing me this exact error. I've done the manual make install as you suggested, and it's still producing the same error.



  • to my experience you not only have to manually make and make install the lib folder in qt5/qttools/src/designer/src/ but also the components folder, as the content of this folder generates libQt5DesignerComponents library



  • This post is deleted!


  • try sudo apt-get build-dep qtcreator .this worked for me


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.