How can I develop qt app for raspberry on desktop



  • I want to develop qt app on my desktop pc and run on raspberry. is it possible ? I found "this video on youtube":http://www.youtube.com/watch?v=pBhT_CINPjE but I did not find necessary tools. How can I do this ?
    I use Arch Linux on my PC.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Sure it's possible, "here":http://qt-project.org/wiki/RaspberryPi_Beginners_guide you have a starting point.

    Qt Creator, a cross-compiler, a working network connection (well two, one for you computer and one for the Raspberry) , if possible a screen for your Pi and basically you're setup



  • I use bakeqtpi script and I get this error

    @.obj/release-shared/qlibrary_unix.o: In function QLibraryPrivate::load_sys()': qlibrary_unix.cpp:(.text+0x1230): warning: Using 'dlopen' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking /home/ekcdr/opt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libdl.a(dlopen.o): In functiondlopen':
    (.text+0xc): undefined reference to __dlopen' /home/ekcdr/opt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libdl.a(dlclose.o): In functiondlclose':
    (.text+0x0): undefined reference to __dlclose' /home/ekcdr/opt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libdl.a(dlsym.o): In functiondlsym':
    (.text+0xc): undefined reference to __dlsym' /home/ekcdr/opt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libdl.a(dlerror.o): In functiondlerror':
    (.text+0x0): undefined reference to __dlerror' /home/ekcdr/opt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libm.a(feholdexcpt.o): In functionfeholdexcept':
    (.text+0x48): undefined reference to _dl_hwcap' /home/ekcdr/opt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libm.a(fesetenv.o): In functionfesetenv':
    (.text+0x64): undefined reference to `_dl_hwcap'
    collect2: hata: ld çıkış durumu 1 ile döndü
    Makefile:681: recipe for target '../../lib/libQt5Core.so.5.0.0' failed
    make[2]: *** [../../lib/libQt5Core.so.5.0.0] Error 1
    make[2]: Leaving directory '/home/ekcdr/opt/qt-everywhere-opensource-src-5.0.0/qtbase/src/corelib'
    Makefile:75: recipe for target 'sub-corelib-make_first' failed
    make[1]: *** [sub-corelib-make_first] Error 2
    make[1]: Leaving directory '/home/ekcdr/opt/qt-everywhere-opensource-src-5.0.0/qtbase/src'
    Makefile:40: recipe for target 'sub-src-make_first' failed
    make: *** [sub-src-make_first] Error 2
    Make failed for QTBase
    @


  • Lifetime Qt Champion

    What options did your build use ?





  • I tried again withou script and same error again. My configure command is @./configure -opengl es2 -device linux-rasp-pi-g++ -device-option CROSS_COMPILE=~/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/rasp-pi-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/qt5pi
    @


  • Lifetime Qt Champion

    Can you try again but without the -reduce-exports option


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.