QT creator: Fancy browser example application doesn't work



  • Hi,

    I am new to QT. I have few issues and would be grateful if any of you could guide me and let me know what am I doing wrong. Following is what I have done.

    I have installed qt-sdk-win-opensource-2010.04.exe from http://qt.nokia.com/downloads/downloads#lgpl (QT SDK for Widnows)

    After installation, I opened QCreator and trying various examples given in that. I clicked on the Run button (on the left panel) after opening selecting the example.

    I was able to successfully run the HTML previewer application. However, I am not able to run the fancy browser application. I am not getting anything in the window though I have entered a valid URL (www.google.com) in the address field.

    I would like to know if I have to do any setting on Windows to run this example successfully? Am I missing anything here?

    Please do the needful.

    Thanks in advance.

    Regards,

    GoGetIt



  • I had faced this problem when there was a proxy in the network; adding this line solved the problem ...

    @
    QNetworkProxyFactory::setUseSystemConfiguration(true);
    @

    I'm using 4.7beta2 and this line is already included in the source, the example ran just fine ..



  • Thanks for the reply Chetan.

    I checked the source code of the demo and saw that the mentioned line of code is already there in mainwindow.cpp, under MainWindow::MainWindow().

    How did you check the version of QT? I checked in QT Creator under Help->About QTCreator. It shows QT4.7.0(32 bit).

    Do I need to install anything else in addition to qt-sdk-win-opensource-2010.04.exe to get the browser related demos to work?

    I even tried running the Browser example under QTDemo->Demonstrations-Browser. Here also, I get the window but nothing after entering the URL and hitting enter.

    Please let me know how to get these demos working.

    Regards,
    GoGetIt



  • only thing I can think of is that there might be a firewall blocking your internet access. were you in a network? if so, can you try from outside that network?



  • Yes, I am in a network.

    While googling I came across a utility which captures the snapshot of web page and is called CutyCapt. This also uses QTWebkit for achieving this. I tried running this app and saw that it gives a blank page as the out put instead of the webpage snapshot.

    Whereas if I run the IECapt utility which also gives snapshot of web page but implemented in C#, it gives proper output and I could see the snapshot of the specified URL.

    So I doub that I might be missing something in case of QT. But I am not getting it.

    Please do the needful.

    Regards,
    Madhu


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.