QtWebEngine extremely slow (windows 7 VS2013 build)



  • Hi,

    I have built the fancybrowser sample (also tried just an empty project with qtwebengine widget on it) and I got a very very slow browser, which takes years to load any simple page.

    An interesting thing: It took 0 CPU but was still very very slow. It looks as if it's waiting for something or someone ... It was also very very slow on a localhost site...

    Please let me know if there's any quick resolution for that, as I am trying to provide a demo of Qt+Web to my team leaders.. and I can't in current condition.



  • I think this issues has something to do with Windows (7) system objects getting hung. It might also be the JetStorm WebStorm IDE which sometimes gets the browsers stuck..

    It does recur however..



  • Some problem on Windows 8.
    On Chrome the same xhtml file is shown smooth and immediate but on a Qt webengine browser extremely slow.



  • I have the same situation on window7 32
    window Qt 5.4.1 app with embedded QWebEngine.

    May be troubles with some of plugins/iconengine/etc?

    btw, I use windeployqt.exe



  • Sorry, I forgot to share:

    the problem (in my case) was that QtWebEngineProcess was compiled in debug mode only so it loaded all the debug libraries, thus very slow.
    I solved (thanks also to Qt support that opened a bug ticket after my support request) executing "jom release" in the directory "qtwebengine/src/process".
    A release version of QtWebEngineProcess.exe will be created in the directory "qtbase/libexec"

    Hope it helps.



  • As I see QtWebEngineProcess.exe has 11264 bytes, and seems it is release build, no?



  • Yes, mine is 12288 (Windows 8), the debug is around 50k.
    So you have another problem, I guess.



  • I have check programm in 32 an 64 bits, with and without OpenGL - result the same.

    On given machine Windows7 Pro 64x QtWebEngine works singnificte slow.
    But on other two machines (Win8 64) it works ok. And ubuntu Ok too.

    So what kind of problem can be? ((



  • Exactly same issue for me. I tried on Macx, no problem. I experience this issue only on Win7 32 with and without OpenGL pre-builds...



  • @trallallero error deply myapp,i see http://forum.qt.io/topic/52335/qwebengine-deploy-problem-qwebprocess-exe but is not useful;
    the qwebengineprocess.exe debug log is
    [0326/201052:WARNING:resource_bundle.cc(286)] locale_file_path.empty()
    how i solve my problem,thank



  • Your demo is long over now, but try disabling not-connected network devices, as suggested here: https://bugreports.qt.io/browse/QTBUG-44763t
    Worked for me when running the FancyBrowser example code


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.