Strange Qt creator behavior - Mac Yosemite and Windows 8.1



  • Hi, I'm running community on both Mac Yosemite and Windows 8.1 64 bit. I have noticed two strange behaviors:

    1. Under mac... sometimes the right clicks simply don't work. For example in form designer, on a button, right click to select goto socket but the right click menu just flashes and goes away. This was on a MBP with a trackpad. When I connected a mouse it seemed better.

    2. Under windows 8.1 sometimes the projects page seems to be missing letters in the buttons and displays. IE new project looks like: N j o c (lots of letter missing). A restart of Qt seems to correct it.

    Anyone else?



  • Hi, yes I have the same problem in mac, when you right click it does not work, the menu flashes for a seconds and diasppears

    Regards
    GOPI



  • Hello,
    I have the same issue with Mac, the right click does not work, I tried to create couple of buttons and tried to "go to slot" by right clicking, the menu flashes for a second and disappears

    regards
    GOPI



  • Same issue here. MBP Retina, Windows 7 in VMware does the same scambling of letters on the home page.



  • I devellop on Linux but a guy trying to build my app on this mac has the same problème. Any known workaround beside control-click?

    Regards,

    Alain



  • I haven't noticed any current problem with a 'right mouse' button click on any of my macs (two MBPs, one iMac running snow leopard, mountain lion, and yosimete).

    I did notice a problem when using older versions of Qt (4.8.x) that were related to the right mouse button (I had to plug in a two button mouse in some cases as a work around). Since switching to 5.3.x and 5.4.0 I have not seen this at all.

    I use the track pad on the two MBPs (right mouse = ctrl + mouse click). I have a single button mouse for my iMac (standard Apple mouse).

    You didn't mention what version of Qt you were using in this post.



  • Sorry.
    QT 5.4.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.