[SOLVED] qmake crashing at startup.



  • Hello.

    At the risk of looking stupid I feel I need to ask here to get this resolved. I have Qt 4.7.2 built from source using the Intel compiler (static / debug and release build only)

    I also have installed Qt Creator v2.1.0 (from binary) based on 4.7.1 (32Bit) but every time I start it I get a crash dialog appearing that produces the following output.
    @
    Problem Event Name: APPCRASH
    Application Name: qmake.exe
    Application Version: 0.0.0.0
    Application Timestamp: 4d988c12
    Fault Module Name: qmake.exe
    Fault Module Version: 0.0.0.0
    Fault Module Timestamp: 4d988c12
    Exception Code: c0000005
    Exception Offset: 0015e509
    OS Version: 6.1.7601.2.1.0.256.28
    Locale ID: 2057
    ...
    @
    When I select the Tools > Options / Qt4 option I am told that the auto detected path is not found. Inspecting the PATH environment shows:-

    C:Qt4.7.2;C:Qt4.7.2bin;...

    Attempting to manually add a version results in the same crash as described above. To resolve this do I have to built Qt Creator as an x64 binary from source? If this is the case then how do I do it?

    Could this also be the source of my other issue "here":http://developer.qt.nokia.com/forums/viewthread/4933/

    Qt SDK v4.7.2
    Windows 7 x64
    Qt Creator v2.1.0
    Intel Compiler v12.0.0.2
    Visual Studio 2010 Pro
    VS Qt Add-in v1.1.19

    --
    Regards,

    William



  • Is anyone able to help me here, I need to get some work done but I am unable to start until I get this issue resolved.

    P.S. The slashes missing from the PATH environment above are there it would appear they have either been stripped out on submission or I made a mistake but the PATH reads:

    C:\Qt\4.7.2;C:\Qt\4.7.2\bin;...

    --
    William


  • Moderators

    Get a backtrace and write a "bug report":http://bugreports.qt.nokia.com/. You are a developer (otherwise you would not care to use Qt Creator), so I am sure you can manage that:-)

    Some details on what you are doing would be really helpful, too. The output you pasted suggests that qmake crashed, while you claim it was Qt Creator, so some clarification would be greatly appreciated.



  • Thanks for the reply Tobias and I hear what you say. To let you understand what is happening this is what I have and have done.

    I compiled Qt from the 4.7.2 source building only 64 bit static libraries in debug and release formats and I have successfully compiled an existing Qt derived project from these libraries using Visual Studio 2010 Pro and the Intel x64 Compiler tool chain.

    However, since my last post I have (out of desperation!) un-installed and re-installed Qt Creator from the downloaded binary. But now when I start Creator qmake no longer terminates but I still have no auto-detected qmake under Tools > Options / Qt4.

    Manually adding the exe results in a message "Could not determine the path to the binaries of the Qt installation, maybe the qmake path is wrong" at the bottom of the dialog just above the buttons.

    I have checked everything I can to ensure correct operation from my limited understanding of Qt (I normally use Visual C++).

    With that said I have just noticed that the time stamp on qmake is a day newer that that of the .lib files, I know the Intel compiler is not the fastest but it never took 24 hours to build!

    As a consequence of this I will rebuild Qt to exclude this from the list of 'suspects'.

    --
    William



  • Well the rebuild of Qt has solved this issue. As it turned out someone had started an x86 build and terminated it realising it was un required but no doubt corrupting qmake in the process. So the re-build was required regardless.

    The rebuild may have fixed this issue however, but it would appear there is a new one with the toolchain support, but that's another post!

    --
    William


  • Moderators

    Repeat after me: There are no issues with the tool chain support.

    If you run into something anyway, please open an issue in our bugtracker and assign it over to me. I wrote it, so unfortunately I will need to fix it, too.



  • "There are no issues with the tool chain support" :-)

    Maybe an unfortunate choice of words.. But if I have a build issue I would be inclined to post here first in case it is 'driver' error. For what it is worth the ONLY compiler we can use is Intel so I may be back!

    --
    William


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.