QT 5.3.2 - Zlib dependency on Fedora Core 21



  • Dear All,

    I am getting following errors:
    @
    /root/SYSROM_SRC/lib/libQt5Network.so: undefined reference to z_inflate' /root/SYSROM_SRC/lib/libQt5Network.so: undefined reference toz_inflateSetDictionary'
    /root/SYSROM_SRC/lib/libQt5Network.so: undefined reference to z_deflateEnd' /root/SYSROM_SRC/lib/libQt5Network.so: undefined reference toz_inflateInit_'
    /root/SYSROM_SRC/lib/libQt5Network.so: undefined reference to z_deflate' /root/SYSROM_SRC/lib/libQt5Network.so: undefined reference toz_inflateEnd'
    /root/SYSROM_SRC/lib/libQt5Network.so: undefined reference to z_deflateInit_' /root/SYSROM_SRC/lib/libQt5Network.so: undefined reference toz_inflateInit2_'
    collect2: error: ld returned 1 exit status
    @

    I am using QT5.3.2 on Fedora Core 21.
    I have also installed zlib package using yum as well as i have tried building it from source and then doing configure.

    The zlib.so file path is set in LD_LIBRARY_PATH as well as in LIBS in make file. But still this error is coming.

    Kindly help me out of this issue.

    Thanks

    Sid



  • Have you installed zlib-devel package?



  • I was getting the exact same error. Running Fedora 21 with zlib-devel installed. It turned out to be some kind of library versioning issue from the pre-built qt5 creator I downloaded from qt.io and installed under /opt.

    Installing qt5-qtbase (and any qt5-qt* modules that you need for your project) via yum fixed this; you have to use the qt creator + qmake-qt5 that comes from the fedora repos, not the pre-built ones from the qt org.

    Once qt5 stuff is installed you can use them in qtcreator pretty easily, just google it for info on how to add different qt versions to qtcreator.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.