[SOLVED] Lots of "header.h: No such file or directory" when configuring Qt5.3 on Ubuntu



  • Here's an excerpt listing all reported errors: http://pastebin.com/1nRa4pzu

    I'm using the qt-everywhere-opensource-src-5.3.2 sources.

    My configure flags are: -release -opensource -confirm-license -c++11 -shared -nomake examples -opengl desktop -fontconfig -gtkstyle -optimized-qmake -qt-xcb -qt-xkbcommon -qt-zlib -qt-pcre -qt-libpng -qt-libjpeg -qt-freetype -qt-harfbuzz -skip qtactiveqt -skip qtconnectivity -skip qtlocation -skip qtmacextras -skip qtmultimedia -skip qtquick1 -skip qtquickcontrols -skip qtsensors -skip qtserialport -skip qtwebchannel -skip qtwebengine -skip qtwebkit -skip qtwebkit-examples -skip qtwebsockets -skip qtwinextras -no-cups -no-nis -no-alsa -no-pulseaudio -no-openssl -L/usr/local/lib

    I tried stripping the majority of the flags (with the exception of -qt-xcb and others where I lack the required libraries), but this error of missing headers persist.

    Here is the configuration summary: http://pastebin.com/dQ1jwTCV

    The Qt libraries probably still build in this configutation, but XCB is listed without GLX support in the report and I think I'll need that.

    Any idea where to start?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.